Opened 4 years ago

Closed 21 months ago

#3167 closed defect (rejected)

[Element Hiding Helper] 'Preview' enabled automatically every two times

Reported by: passbrains Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: kzar Blocked By:
Blocking: Platform: Firefox
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by Shikitita)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=AEH-2

Environment

Windows + 10 Technical Preview (x64) + Firefox + English
ABP version 2.6.10.3979-beta

How to reproduce

  1. Install adblock plus and Element Hiding Helper for adblock plus
  2. Access wwww.timesofindia.indiatimes.com
  3. Click on the ABP icon and then on 'Select an element to hide'
  4. Select an element to hide
  5. Disable 'Preview' in 'Compose element hiding rule' dialog window
  6. Click on 'Add element hiding rule'
  7. Click on the ABP icon and then on 'Select an element to hide'
  8. Select any element to hide
  9. Click on 'Add element hiding rule'
  10. Click on the ABP icon and click 'Select an element to hide'
  11. Select any element to hide

Observed behaviour

After step 11, 'Preview' is enabled despite having been disabled in the first place as well as having been displayed as disabled the second time.

Expected behaviour

After step 8 and 11, 'Preview' should still be disabled.

Attachments (1)

3766_1442834824_eHHPreview.mp4 (2.5 MB) - added by passbrains 4 years ago.

Download all attachments as: .zip

Change History (3)

Changed 4 years ago by passbrains

comment:1 Changed 4 years ago by Shikitita

  • Description modified (diff)
  • Summary changed from 'Preview' is enabled automatically when element is selected to hide every alternate time. to [Element Hiding Helper] 'Preview' enabled automatically every two times

comment:2 Changed 21 months ago by kzar

  • Cc kzar added
  • Resolution set to rejected
  • Status changed from new to closed

Unfortunately the Element Hiding Helper is no longer under development since the switch to Firefox WebExtensions. I'm closing this issue therefore.

P.S. Apparently the extensions-for-adblock-plus module doesn't exist any more so I can't correct the module of this issue :/

Note: See TracTickets for help on using tickets.