Opened 4 years ago

Closed 5 weeks ago

#3187 closed change (duplicate)

Add tests for Acceptable Ads detection to testpages

Reported by: greiner Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: Ross, saroyanm, hseydel Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Background

We provide whitelisting partners with the ability to check whether Acceptable Ads is enabled or not for performance measurements. Therefore we need to ensure that the extension always behaves the same.

What to change

  • Add a 1x1 pixel image px.gif
  • Add the following filters to exceptionrules.txt (may vary depending on the final URL of the image):
    @@||testpages.adblockplus.org/px.gif?ch=1^$domain=testpages.adblockplus.org
    ||testpages.adblockplus.org/px.gif?ch=2^$domain=testpages.adblockplus.org
    
  • Add a new test checking the results of the following requests:
    • /px.gif?ch=1 should succeed (i.e. 2xx or 3xx response codes)
    • /px.gif?ch=2 should fail (i.e. 4xx or 5xx response codes)

Change History (8)

comment:1 Changed 4 years ago by saroyanm

  • Cc saroyanm added

comment:2 Changed 3 years ago by juliandoucette

  1. Is this still relevant?
  2. We should split this up into two issues because exceptionrules.txt is not part of testpages.adblockplus.org?

comment:3 Changed 3 years ago by greiner

  • Cc hseydel added

Is this still relevant?

Unless Henning disagrees, I'd still consider this to be relevant.

comment:4 Changed 3 years ago by juliandoucette

  • Priority changed from Unknown to P5

comment:5 Changed 2 years ago by juliandoucette

I don't know how to move this forward @greiner.

comment:6 Changed 2 years ago by greiner

Neither do I. Note that it affects testpages.adblockplus.org so we probabaly need Ross for that since he's the owner of this repository because it's not part of any module.

comment:7 Changed 19 months ago by juliandoucette

  • Component changed from Websites to Unknown
  • Priority changed from P5 to Unknown

comment:8 Changed 5 weeks ago by greiner

  • Resolution set to duplicate
  • Status changed from new to closed

Closing this ticket as duplicate of AAP-942 (internal).

Note: See TracTickets for help on using tickets.