Opened 4 years ago

Closed 4 years ago

#3205 closed defect (fixed)

Redirection to Adblock Browser app page in App Store is broken

Reported by: saroyanm Assignee: saroyanm
Priority: P1 Milestone:
Module: Websites Keywords:
Cc: fhd, matze, philll Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29329141/
https://codereview.adblockplus.org/29329146/

Description

Environment

Safari on Ios Devices

How to reproduce

  1. Navigate to adblockplus.org
  2. Click on Download Adblock Browser button
  3. Observe

Observed behaviour

Blank screen shown

Expected behaviour

Redirection to Adblock Browser profile page in App Store

Change History (13)

comment:1 Changed 4 years ago by saroyanm

  • Cc fhd added

According to the fix this could become infrastructure ticket.

comment:2 Changed 4 years ago by philll

Looks like the URL changed from https://itunes.apple.com/us/app/adblock-browser/id1015653330?ls=1&mt=8 to https://geo.itunes.apple.com/us/app/adblock-browser-best-ad-blocker/id1015653330?mt=8 which indicates the app name / title has changed. I fear we created that issue ourselves that way. Whenever we in future change that title, we need to think about the links/redirects to it.

comment:3 Changed 4 years ago by philll

Looks like the URL changed from https://itunes.apple.com/us/app/adblock-browser/id1015653330?ls=1&mt=8 to https://geo.itunes.apple.com/us/app/adblock-browser-best-ad-blocker/id1015653330?mt=8 which indicates the app name / title has changed. I fear we created that issue ourselves that way. Whenever we in future change that title, we need to think about the links/redirects to it.

comment:4 Changed 4 years ago by saroyanm

  • Component changed from Websites to Infrastructure

This is infrastructure ticket while we have redirection setup in infrastructure module

comment:5 Changed 4 years ago by matze

  • Cc matze added
  • Owner set to saroyanm

comment:6 Changed 4 years ago by saroyanm

  • Status changed from new to reviewing
Last edited 4 years ago by saroyanm (previous) (diff)

comment:7 Changed 4 years ago by saroyanm

  • Review URL(s) modified (diff)

comment:8 Changed 4 years ago by saroyanm

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:9 Changed 4 years ago by saroyanm

  • Component changed from Infrastructure to Unknown
  • Resolution fixed deleted
  • Status changed from closed to reopened

The issue still exists, changed the module while we are not sure which module the issue is affected by.

comment:10 Changed 4 years ago by matze

The redirect itself looks like being setup as intended:

$ wget -q -S https://adblockplus.org/redirect?link=adblock_browser_ios_store 2>&1 | grep Location
  Location: https://geo.itunes.apple.com/us/app/adblock-browser-best-ad-blocker/id1015653330?mt=8
  Location: https://itunes.apple.com/de/app/adblock-browser-best-ad-blocker/id1015653330?mt=8&uo=4
  Location: https://itunes.apple.com/de/app/adblock-browser-best-ad-blocker/id1015653330?mt=8&ign-mpt=uo%3D4

Please make sure the issue does not persist due to e.g. caching only.

comment:11 Changed 4 years ago by saroyanm

  • Cc philll added

Yes me and @Phill are testing right now, trying to be sure it's nothing related to cache.

comment:12 Changed 4 years ago by saroyanm

  • Review URL(s) modified (diff)
  • Status changed from reopened to reviewing

comment:13 Changed 4 years ago by saroyanm

  • Component changed from Unknown to Websites
  • Resolution set to fixed
  • Status changed from reviewing to closed

The another reason was because of safari were having issue opening the store link in new tab for some reason.

Note: See TracTickets for help on using tickets.