Opened 4 years ago

Closed 4 years ago

#3212 closed change (duplicate)

Management of pattern file for large scale deployment for Chrome is outdated

Reported by: axie Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords:
Cc: greiner, kzar, sebastian, mapx, simona Blocked By:
Blocking: Platform: Chrome
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Background

Currently the instructions in the "How-to: Create ABP Deployment Package" for managing the pattern file is outdated. It said we need to go to C:\Users\%username%\AppData\Local\Google\Chrome\User Data\Default\File System\000\p\00 and copy the 00000000 file, which no longer exists. Seems like the pattern file or its settings are now located in C:\Users\%username%\AppData\Local\Google\Chrome\User Data\Default\Local Extension Settings\cfhdojbkjhnklbpkdaibdccddilifddb. In there there is a .log file, which seems to hold the subscriptions and stuff, but the file name keeps on incrementing by 1 (ex 000003.log => 000004.log).

In order for me to have all the users to have the same subscriptions I've setup, I need to:

1) Copy the 00000X.log file in my profile and name it 000003.log, and put that on the file share.
2) On other users profiles, all files in their "Local Extension Settings\cfhdojbkjhnklbpkdaibdccddilifddb" directory need to be deleted (while Chrome is closed).
3) Copy the 000003.log into that directory and open Chrome. Now their subscriptions are the same as mine. Only the "Allow some non-intrusive advertising (disabled)" isn't saved.

While this works, the .log filename keeps on changing and sometimes it goes to 0 bytes (I'm assuming it also acts as a log file). We can't have the GPO to push out and replace the file since it's keep changing (unless I deploy the file via a script).

What to change

We need a better way to manage subscriptions and settings on a file system level so that we can sync settings across thousands of users easily.

Change History (3)

comment:1 Changed 4 years ago by mapx

  • Cc greiner kzar sebastian mapx added
  • Component changed from Unknown to Platform

comment:2 Changed 4 years ago by mapx

please note those "instructions" were provided by a forum user and not by the devs
https://adblockplus.org/forum/viewtopic.php?p=122791#p122791

comment:3 Changed 4 years ago by kzar

  • Cc simona added
  • Resolution set to duplicate
  • Status changed from new to closed

Hi Axie, unfortunately managing subscriptions and custom filters of users for "large scale deployments" is not something that we currently support (those instructions you've been following are unofficial as mapx mentioned).

This ticket is also a duplicate of #420.

I've copied Simona in on this ticket in case she has any advice for you, she is quite knowledgeable about this topic, perhaps she can help you further.

Note: See TracTickets for help on using tickets.