Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#3213 closed defect (worksforme)

Whitelisted ads on suche.web.de not showing

Reported by: arthur Assignee:
Priority: P1 Milestone:
Module: Adblock-Plus-for-Firefox Keywords:
Cc: trev Blocked By:
Blocking: Platform: Firefox
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

  • Windows 10 Pro
  • Firefox 41.0.2
  • Adblock Plus 2.6.11.3990 and newer
  • EasyList Germany+EasyList
  • Acceptable Ads enabled

How to reproduce

  1. Go to http://web.de/
  2. Search for "iphone" with the Google search bar

Observed behaviour

Below "Anzeigen zu: iphone" regular search results appear without AdSense for Search ads. Disabling Adblock Plus for suche.web.de still doesn't make them appear, only if you disable it everywhere from the context menu.

Expected behaviour

Whitelisted search ads should appear.

In the current stable version of Firefox and Adblock Plus this is working fine. This seems to happen for dev builds after 2.6.11.3989. This is also reproducible in the latest Nightly (but also with 2.6.11 stable).

Change History (8)

comment:1 Changed 4 years ago by trev

  • Blocked By 3208 added
  • Ready set

Testing shows that this issue was indeed introduced in #3108, and fixed by https://codereview.adblockplus.org/29329562/ from #3208. Please retest once this change lands.

comment:2 Changed 4 years ago by trev

  • Blocked By 3208 removed

I can still reproduce this issue with 2.6.11.4024-beta, looks like it wasn't fixed by that change after all.

comment:3 Changed 4 years ago by arthur

Yes, same for me.

comment:4 Changed 3 years ago by trev

Appears to be working correctly in 2.6.13.4087-beta for me. What about you, do you still see this issue?

comment:5 Changed 3 years ago by arthur

WFM.

comment:6 Changed 3 years ago by trev

  • Resolution set to worksforme
  • Status changed from new to closed

Great, thank you!

comment:7 Changed 3 years ago by arthur

Looks like it's still or again happening.

  • Windows 10 Pro
  • Firefox 44.0.2
  • Adblock Plus 2.7.1.4139
  • EasyList Germany+EasyList
  • Acceptable Ads enabled

It doesn't happen for me if I search for "hotel" or "iphone" but "unique gifts" triggers it for some reason.

Last edited 3 years ago by arthur (previous) (diff)

comment:8 Changed 3 years ago by trev

This doesn't seem to be the same issue. My analysis shows that Google's async-ads.js expects that the size of the frame content can be calculated synchronously - with an element hiding filter potentially applying to it this calculation occasionally goes wrong however. So in this particular case the content of the frame shows up correctly but the frame size is too small so that everything but the top 16 pixels is cut off. I'm not sure why it doesn't always happen but I think that #524 is the only generic solution on our side. Otherwise one would have to address this by removing the filter causing it (##.ad in EasyList, limited to lots of domains including www.google.com).

Note: See TracTickets for help on using tickets.