Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#3218 closed defect (rejected)

[Adblock Browser for iOS] New Tab opened when searching in kayak.de

Reported by: Shikitita Assignee:
Priority: P1 Milestone:
Module: Adblock-Browser-for-iOS Keywords: salsita
Cc: pavelz, jand, vojtab, michal.kuric, mario Blocked By:
Blocking: Platform: Adblock Browser for iOS
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

Platform: iPhone 5s
Operating system: iOS 8.4
Browser: Adblock Browser for iOS v. 1.2.0-STAGE (522)

How to reproduce

  1. Install Adblock Browser for the first time and launch it
  2. Access the website kayak.de by tapping on the URL Search bar at the top of the screen where "Search or enter website name" can be read
  3. Tap on "Menü" at the top right of the screen
  4. Tap on "Desktop-Seite"
  5. Enter a random city and date in order to perform a search
  6. Tap on "Suchen"

Observed behaviour

A New Tab opens without any other information than the Dashboard.

Expected behaviour

A New Tab should open with information from other travelling websites.

This could be the same behaviour observed in Firefox, where three different tabs open after clicking on "Suchen" displaying each a different travelling website.

Change History (4)

comment:1 Changed 4 years ago by pavelz

  • Priority changed from Unknown to P1

comment:2 Changed 4 years ago by pavelz

  • Resolution set to rejected
  • Status changed from new to closed

Cannot work in ABB and in iOS browsers in general. Chrome (as the only other 3rd party iOS browser capable of opening new windows) does the same thing as ABB: it opens new about:blank window. All other browsers do nothing, even Safari which has greater control over iOS internals. The core issue is that kayak javascript does window.open with empty URL and wants to operate on the returned window object. A 3rd party iOS browser cannot simply provide such window object. An url setter hack could be theoretically implementable, but it is an inadequate effort for a site where normally operable mobile version exists. Any kind of hack would be a temporary whack-a-mole anyway, because the client javascript code may also want to use the pretend window object for further arbitrary actions which cannot be implemented even theoretically.

comment:3 Changed 4 years ago by mario

  • Milestone set to Adblock-Browser-for-iOS-next

Batch Modify: Added milestone Adblock-Browser-for-iOS-next for upcoming release.

comment:4 Changed 4 years ago by mario

  • Milestone Adblock-Browser-for-iOS-1.2.0 deleted
Note: See TracTickets for help on using tickets.