Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#3237 closed defect (fixed)

Whitelisted AFS ad is not shown on netzwelt.de

Reported by: sergz Assignee: oleksandr
Priority: P1 Milestone: Adblock-Plus-for-Internet-Explorer-1.6
Module: Adblock-Plus-for-Internet-Explorer Keywords:
Cc: oleksandr, sergz, eric@…, greiner Blocked By:
Blocking: #3368 Platform: Internet Explorer
Ready: yes Confidential: no
Tester: Rraceanu Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29331669/

Description (last modified by oleksandr)

Environment

IE 11, ABP 1.5, EasyList Germany+EasyList, Allow some non-intrusive advertising is enabled.

How to reproduce

  1. Go to http://netzwelt.de
  2. search for something, iphone for example

Observed behaviour

AFS is not shown

Expected behaviour

AFS should be shown.

Additional info

Request http://cse.google.com/cse?q=iphone&r=m&cx=0... is detected as IMAGE because Accept header is text/html, application/xhtml+xml, image/jxr, */*, so the request is blocked, however fixing only of this request is not enough.

Additionally the ad is also hidden. The whitelisting filter: @@
google.com/cse?$subdocument,document,domain=netzwelt.de should be applied, but due to incorrect ShouldBlock call, domain is not resolved.

Change History (11)

comment:1 Changed 4 years ago by sergz

Merely for reference, it's not a duplicate of #1210

comment:2 Changed 4 years ago by oleksandr

  • Platform changed from Unknown / Cross platform to Internet Explorer
  • Priority changed from Unknown to P2
  • Ready set

comment:3 Changed 4 years ago by oleksandr

  • Cc sergz eric@… added
  • Priority changed from P2 to P1

comment:4 Changed 4 years ago by oleksandr

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:5 Changed 4 years ago by oleksandr

  • Description modified (diff)
  • Owner set to oleksandr

comment:6 Changed 4 years ago by oleksandr

  • Blocking 3368 added

comment:7 Changed 4 years ago by greiner

  • Cc greiner added

comment:8 Changed 4 years ago by oleksandr

  • Resolution set to fixed
  • Status changed from reviewing to closed

This has been pushed: https://hg.adblockplus.org/adblockplusie/rev/ffd5291ca115. This and #3368 both seem to be fixed now. A fix will be included in a nearest devbuild, which we can build once #3412 is fixed.

comment:9 Changed 4 years ago by oleksandr

  • Milestone set to Adblock-Plus-for-Internet-Explorer-Next

comment:10 Changed 3 years ago by rraceanu

  • Tester changed from Unknown to Rraceanu

comment:11 Changed 3 years ago by rraceanu

  • Verified working set

Change successfully implemented, Whitelisted ads are shown with Easylist Germany+ Easylist and AA enabled on netzwelt.de whilst doing a search query, verified on IE 10 Windows 8 and IE 11 Windows 10, ABP version 1.5.856.

Last edited 3 years ago by rraceanu (previous) (diff)
Note: See TracTickets for help on using tickets.