Opened 2 years ago

Closed 13 months ago

Last modified 5 months ago

#3247 closed defect (fixed)

Closing the browser shortly after initial launch(s) causes no filters lists to be selected

Reported by: Ross Assignee: diegocarloslima
Priority: P3 Milestone: Adblock-Browser-for-Android-1.2.0
Module: Adblock-Browser-for-Android Keywords:
Cc: Blocked By:
Blocking: Platform: Adblock Browser for Android
Ready: no Confidential: no
Tester: Scheer Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29350137/

Description

Environment

Adblock Browser 1.0.0.201510
Xperia Z / Android 5.0.2

How to reproduce

  1. Open the Settings > App menu on the device.
  2. Force stop and clear data for Adblock Browser.
  3. Launch Adblock Browser.
  4. When the FRP appears, close the Adblock Browser via device task menu (swipe away).
  5. Launch Adblock Browser again.
  6. When the homescreen appears, count to 2.
  7. Close Adblock Browser via device task menu (swipe away) again.
  8. Launch Adblock Browser again.
  9. Select [Menu] > [Settings] > [Ad blocking] > [Ad blocking].
  10. Observe the filter list has been fetched already.
  11. Observe no filter list has been "default selected"

Observed behaviour

After performing the steps above the user will have no filter list default selected. Step 6 is important because if the browser is closed again too early or too late they will have a filter list default selected as expected.

It doesn't matter if they skip or pass through the FRP in Step 4.

Expected behaviour

The user should always have a filter list default selected however they close/mess around with the browser's initial launches.

Change History (7)

comment:1 Changed 2 years ago by Ross

This might be the cause of some users having no filter lists active after their initial install. The 2 second wait at Step 6 seems to matter and I can constantly reproduce it.

Noticed this when an automated test kept causing the conditions.

comment:2 Changed 2 years ago by fhd

  • Milestone Adblock-Browser-for-Android-1.1.0 deleted

comment:3 Changed 16 months ago by diegocarloslima

  • Owner set to diegocarloslima

comment:4 Changed 15 months ago by diegocarloslima

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:6 Changed 13 months ago by diegocarloslima

  • Milestone set to Adblock-Browser-for-Android-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:7 Changed 5 months ago by scheer

  • Tester changed from Ross to Scheer
  • Verified working set
  • The user now always has a filter list by default selected even with the browser start up closing as described above.

ABB adblockbrowser-1.1.1.20170612182010-arm
Galaxy S7
Android 7.0

ABB adblockbrowser-1.1.1.20170612182010-arm
Xperia Z
Android 5.0.2.

Note: See TracTickets for help on using tickets.