Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#328 closed defect (fixed)

ABP doesn't respect the system locale when adding a filter list

Reported by: arthur Assignee:
Priority: P2 Milestone: Adblock-Plus-for-Android-1.3
Module: Adblock-Plus-for-Android Keywords:
Cc: Blocked By:
Blocking: Platform: Android
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/6603326711922688/

Description

Environment

Nexus 5
Android 4.4.2
Rooted
Ablock Plus for Android 1.2.1
System locale set to German

How to reproduce

  1. Install the app

Observed behaviour

Adblock Plus selects "EasyList" as the default filter list.

Expected behaviour

Since the system locale is German, "EasyList Germany+EasyList" should be selected by default. This probably also affects other locales as well.

Change History (3)

comment:1 Changed 5 years ago by rjeschke

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 5 years ago by rjeschke

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:3 Changed 5 years ago by trev

  • Milestone set to Adblock-Plus-for-Android-1.3
  • Platform set to Android
Note: See TracTickets for help on using tickets.