Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#3300 closed defect (fixed)

Facebook preview images not showing

Reported by: arthur Assignee:
Priority: P3 Milestone: Adblock-Plus-for-Internet-Explorer-1.6
Module: Adblock-Plus-for-Internet-Explorer Keywords:
Cc: sergz, oleksandr Blocked By: #3303, #3343
Blocking: Platform: Internet Explorer
Ready: no Confidential: no
Tester: Rraceanu Verified working: yes
Review URL(s):

Description

Environment

ABP 1.5
EasyList enabled
IE 11.0.10240.16431
Windows 10

How to reproduce

  1. Go to https://www.facebook.com/AnimalEqualityGermany/posts/954896191250874

Observed behaviour

The preview image in the post is showing for a split second (when refreshing via Ctrl+F5) and then disappears. Disabling ABP for facebook.com makes it appear again.

Expected behaviour

The image should always show.

Change History (11)

comment:1 Changed 4 years ago by sergz

It's blocked by CPluginDomTraverser, for img tags it checks whether the request in src should be blocked or not and hides the element if src is blocked. In this particular case the URL is https://external-frt3-1.xx.fbcdn.net/safe_image.php?d=AQDG18hXt4a9ZX9b&w=470&h=246&url=https://www.facebook.com/ads/image/?d=AQLBPIefFK_mcLEvFR-mVwHgciv-NMbof-t6UHSCX76geZci_sFNFvKnjbX5wekR58St4JQM8Gyb5uC2HL_4JEAr21I9_kSY_cS9ZDopWQKqpfarzLe_AApWcqjl4T0-YgngkHPjujuuMiYlfkl_urqt&cfs=1&upscale=1 and the corresponding blocking filter is /ads/image/*.

FYI: #3303.

The question is, how to fix it?

comment:2 Changed 4 years ago by sergz

Interesting that neither in Firefox nor in Chrome the URL seems to be not decoded before matching the filter, so it is the reason it's not blocked there.

comment:3 Changed 4 years ago by oleksandr

  • Priority changed from Unknown to P3
  • Ready set

Chrome uridecodes the address part of the URL, leaving the query string intact. We should do the same.

comment:4 Changed 4 years ago by oleksandr

  • Blocked By 3303 added

comment:5 Changed 4 years ago by oleksandr

  • Ready unset

comment:6 Changed 4 years ago by oleksandr

  • Blocked By 3343 added

comment:7 Changed 3 years ago by eric@…

We've retired #3343. Did that change fix this problem?

comment:8 Changed 3 years ago by oleksandr

  • Resolution set to fixed
  • Status changed from new to closed

Yes, it seems like it is fixed now, based on my tests. This should be included in the next devbuild and ABP for IE 1.6

comment:9 Changed 3 years ago by oleksandr

  • Milestone set to Adblock-Plus-for-Internet-Explorer-Next

comment:10 Changed 3 years ago by rraceanu

  • Tester changed from Unknown to Rraceanu

comment:11 Changed 3 years ago by rraceanu

  • Verified working set

Fix implemented successfully on ABP for IE 1.5.856 for IE 11.447.14393.0 and IE 11.103.14393.0 Windows 10 Home and Pro, also IE 10 on Windows 8, preview thumbnails load correctly.

Last edited 3 years ago by rraceanu (previous) (diff)
Note: See TracTickets for help on using tickets.