Opened 4 years ago

Closed 2 years ago

#3313 closed defect (fixed)

Adblock Browser for Android triggers wrong redirect on youtube.com for some videos

Reported by: philll Assignee:
Priority: P3 Milestone:
Module: Adblock-Browser-for-Android Keywords:
Cc: Blocked By:
Blocking: Platform: Adblock Browser for Android
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by philll)

Environment

Nexus 7
Android 6.0
Adblock Browser for Android 1.0.0.20151013102229
Easylist
No Youtube app installed (!)
Non-German IP address

Original report from https://adblockplus.org/forum/viewtopic.php?f=24&t=41991&p=142529#p141449

How to reproduce

  1. Open https://www.youtube.com/watch?v=pUjE9H8QlA4
  2. Tap the play button

Observed behaviour

A redirect to https://www.youtube.com/embed/pUjE9H8QlA4?vndclient=mv-google&vndapp=youtube_mobile&vndel=watch&vnddnc=1 happens and the message appears:

This video contains content from VEVO. It is restricted from playback on certain sites.
Watch on YouTube.

With Firefox mobile and Adblock Plus with Easylist installed, the video just plays.

Expected behaviour

The video should play.

Change History (4)

comment:1 Changed 4 years ago by philll

  • Description modified (diff)

comment:2 Changed 2 years ago by diegocarloslima

This issue seems to be solved. I was able to reproduce it on ABB 1.0 but it didn't occur in ABB merge 45.0.3

Environment

abb-merge-45-0-2-build-3-signed-zipaligned.apk
Samsung Galaxy S7 edge
Android 7.0

comment:3 Changed 2 years ago by diegocarloslima

  • Priority changed from Unknown to P3

comment:4 Changed 2 years ago by diegocarloslima

  • Component changed from Unknown to Adblock-Browser-for-Android
  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.