Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#3346 closed change (fixed)

Remove edge subscription form

Reported by: saroyanm Assignee: saroyanm
Priority: P1 Milestone:
Module: Websites Keywords:
Cc: fhd, oleksandr, matze, lisabielik Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29330735/

Description (last modified by saroyanm)

Background

Subscription confirmation mails are blocked by various providers (mostly Microsoft) as described by #3204, this may require a more sophisticated mail solution in general on our side which we do not have right now, so while our users can't get emails doesn't make sense to have this form.

What to change

Remove the subscription form implementation from https://adblockplus.org/en/edge and revert back as soon the issue is fixed.
Add text below instead of form:
Please check back later for a version of Adblock Plus for Microsoft Edge.

Change History (10)

comment:1 Changed 4 years ago by saroyanm

  • Owner set to saroyanm

comment:2 Changed 4 years ago by saroyanm

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:3 Changed 4 years ago by philll

  • Description modified (diff)

comment:4 follow-up: Changed 4 years ago by saroyanm

  • Cc lisabielik added

@lisa we would like to add a message to desktop and mobile version of the page saying something like Please check back later for a version of Adblock Plus for Microsoft Edge. can you please review the text ?
The problem is that on mobile version we are not showing the "Adblock Plus for Microsoft Edge" promo image and it's no message visible to mobile users describing what the page is for.
The text will appear instead of Install button.
If you are okey with text I'll update the ticket and add the text.

comment:5 in reply to: ↑ 4 ; follow-up: Changed 4 years ago by lisabielik

Replying to saroyanm:

@lisa we would like to add a message to desktop and mobile version of the page saying something like Please check back later for a version of Adblock Plus for Microsoft Edge. can you please review the text ?
The problem is that on mobile version we are not showing the "Adblock Plus for Microsoft Edge" promo image and it's no message visible to mobile users describing what the page is for.
The text will appear instead of Install button.
If you are okey with text I'll update the ticket and add the text.

I think the current text is fine: Please check back later for a version of Adblock Plus for Microsoft Edge.

comment:6 in reply to: ↑ 5 Changed 4 years ago by saroyanm

  • Description modified (diff)

Replying to lisabielik:

I think the current text is fine: Please check back later for a version of Adblock Plus for Microsoft Edge.

Thanks

comment:7 Changed 4 years ago by saroyanm

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:8 follow-ups: Changed 4 years ago by oleksandr

I have just realized that this also shows the Microsoft Edge message to ALL users on mobile. Its great for Microsoft Edge, of course :), but I think it should show the message only for those who navigate to the page using Microsoft Edge on Windows 10 Mobile.

comment:9 in reply to: ↑ 8 Changed 4 years ago by saroyanm

Replying to oleksandr:

I have just realized that this also shows the Microsoft Edge message to ALL users on mobile. Its great for Microsoft Edge, of course :), but I think it should show the message only for those who navigate to the page using Microsoft Edge on Windows 10 Mobile.

I think it's shows the message to on all pages, hmm.. I think it's should be available only on edge page.. praparing patch.

comment:10 in reply to: ↑ 8 Changed 4 years ago by saroyanm

Replying to oleksandr:

I have just realized that this also shows the Microsoft Edge message to ALL users on mobile. Its great for Microsoft Edge, of course :), but I think it should show the message only for those who navigate to the page using Microsoft Edge on Windows 10 Mobile.

YOu are right, the patch is ready.

Note: See TracTickets for help on using tickets.