Opened 4 years ago

Closed 3 weeks ago

#3353 closed defect (rejected)

Filterlists load only when preferences are opened

Reported by: Asango Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords: closed-in-favor-of-gitlab
Cc: kzar Blocked By:
Blocking: Platform: Firefox
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

Win 7 Home Premium SP1
Firefox 40.0.2
ABP 2.6.13
Works the same for all filterlist combinations

How to reproduce

TESTED ONLY ON MY 13 YEAR OLD PC:
-Open Firefox
-Open any page, ABP does not block ads until preferences are opened and pages are reloaded

Observed behaviour

Opening filter preferences makes the filterlists load and fixes the bug (until I restart Firefox), while the filterlists are loading it behaves as if there were no filters installed (tells me that no lists are installed and that nothing will be blocked, list is empty).

Expected behaviour

ABP should load the filterlists when Firefox starts, there should be no necessarity to open the preferences to make ABP work.

Change History (2)

comment:1 Changed 21 months ago by kzar

  • Cc kzar added
  • Component changed from Unknown to Platform

Please can you confirm if this is reproducable with the latest version of Adblock Plus 3.0.2 for Firefox? (I ask since the extension has changed dramatically with the switch to Firefox WebExtensions.)

comment:2 Changed 3 weeks ago by sebastian

  • Keywords closed-in-favor-of-gitlab added
  • Resolution set to rejected
  • Status changed from new to closed

Sorry, but we switched to GitLab. If this issue is still relevant, please file it again in the new issue tracker.

Note: See TracTickets for help on using tickets.