Opened 4 years ago

Closed 4 years ago

#3354 closed change (fixed)

[CMS] Enable markdown.extensions.extra extension

Reported by: kzar Assignee: kzar
Priority: P2 Milestone:
Module: Sitescripts Keywords: cms, markdown
Cc: saroyanm, trev, sebastian Blocked By:
Blocking: #3257 Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29331049/

Description (last modified by kzar)

Background

Sometimes it's useful to have a Markdown file that contains HTML elements. This works fine generally, but not with block level elements. Luckily the markdown package contains an extension for this.

With the extension enabled HTML block elements with a truthy markdown attribute will have their contents rendered as Markdown. For example <div markdown="1">**Hello world**</div>.

What to change

Enable the markdown.extensions.extra extension for the markdown renderer in cms/converters.py.

Change History (3)

comment:1 Changed 4 years ago by kzar

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

I have tested and this change has no effect on how web.adblockplus.org, web.adblockbrowser.org and testpages.adblockplus.org are rendered.

I noticed one change to how web.eyeo.com is rendered, but it actually fixes a bug. It turns out we're already this feature in web.eyeo.com/includes/contact/form.md despite the extension not being enabled. I suppose the server must be somehow configured differently as the problem is not present on the live website.

comment:2 Changed 4 years ago by kzar

  • Description modified (diff)

comment:3 Changed 4 years ago by kzar

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.