Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#3360 closed defect (fixed)

Adblock Browser doesn't display acceptable ads on ebay.com (desktop version)

Reported by: mario Assignee:
Priority: P2 Milestone: Adblock-Browser-for-iOS-1.3.0
Module: Adblock-Browser-for-iOS Keywords: salsita
Cc: Blocked By:
Blocking: Platform: Adblock Browser for iOS
Ready: yes Confidential: no
Tester: Scheer Verified working: yes
Review URL(s):

Description (last modified by mario)

Environment

iPhone 6
iOS 9.1
ABB 1.2.0 (681)

How to reproduce

  1. In ABB open http://www.ebay.com/
  2. In the footer of the page tap "Classic site" to switch to the desktop version of eBay
  3. Search for "Mobile Phone" using the eBay search bar at the top of the page

Observed behaviour

There is no Google sponsored links shown below the search results.
(Please note that this only happens in the desktop version of eBay.)

Expected behaviour

Google sponsored links (acceptable ads) should be shown below the search results as shown in this screenshot.

Attachments (3)

Bildschirmfoto 2015-12-01 um 11.20.00.png (460.5 KB) - added by mario 4 years ago.
IMG_3680.PNG (354.0 KB) - added by pavelz 4 years ago.
Capture.PNG (360.2 KB) - added by scheer 4 years ago.

Download all attachments as: .zip

Change History (11)

Changed 4 years ago by mario

comment:1 Changed 4 years ago by mario

  • Description modified (diff)

comment:2 Changed 4 years ago by mario

  • Priority changed from Unknown to P2
  • Ready set

comment:3 Changed 4 years ago by mario

  • Milestone Adblock-Browser-for-iOS-next deleted

Changed 4 years ago by pavelz

comment:4 Changed 4 years ago by pavelz

Blocked. eBay classic site stopped showing AAs to me altogether on iPhone, regardless of VPN setting AND THE BROWSER. I keep seeing AAs on MOBILE site consistently, in the expected language per VPN setting.

Please verify with VPN. I will try again later, maybe tomorrow as well. Currently i'm just bleeding hours because the debugging landscape is unstable. Besides Germany to simulate your location, i have tried also UK(London) and USA West Coast.

Attaching a screenshot of Safari incognito tab with VPN set to USA.

comment:5 Changed 4 years ago by pavelz

When testing the VPN, please close/reopen the browser and use a new incognito tab every time the VPN is switched on-off or the endpoint is changed. Ebay seems to be hooked quite a lot to the established session and definitely carries the AA behavior over the IP change.

comment:6 Changed 4 years ago by pavelz

  • Resolution set to fixed
  • Status changed from new to closed

comment:7 Changed 4 years ago by mario

  • Milestone set to Adblock-Browser-for-iOS-next

Batch modify: added Adblock-Browser-for-iOS-next milestone.

Changed 4 years ago by scheer

comment:8 Changed 4 years ago by scheer

  • Tester changed from Unknown to Scheer
  • Verified working set

Google sponsored links worked for me following the steps above.

ABB 1.3.0-qa (814)
iPhone 6S Plus - iOS 9.1
iPhone 5 16GB - iOS 9.2.1

Note: See TracTickets for help on using tickets.