Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#3368 closed defect (fixed)

Whitelisted ads not shown on ask.com

Reported by: greiner Assignee: oleksandr
Priority: P2 Milestone: Adblock-Plus-for-Internet-Explorer-1.6
Module: Adblock-Plus-for-Internet-Explorer Keywords:
Cc: oleksandr Blocked By: #3237
Blocking: Platform: Internet Explorer
Ready: yes Confidential: no
Tester: Rraceanu Verified working: yes
Review URL(s):

Description

Environment

Windows 7 SP1
Internet Explorer 8
Adblock Plus 1.5 with default settings (EasyList + Acceptable Ads enabled)

How to reproduce

  1. Go to http://de.ask.com/web?q=credit

Observed behaviour

No ads are shown above or below the organic search results.

Expected behaviour

Ads are shown both above and below the organic search results.

Additional information

Investigating the page with IE's developer tools shows that the iFrame .ad-top > iframe - which shows the page "http://www.google.com/afs/ads?q=credit&..." - was blocked by Adblock Plus as indicated by the comment <!-- blocked by AdblockPlus -->. However, the Acceptable Ads whitelist contains the following filter to unblock this frame which works in other versions of Adblock Plus:

@@||google.com/afs/$script,subdocument,document,domain=ask.com|about.com|pageset.com|pronto.com|shop411.com|consumersearch.com|urbanspoon.com|myway.com|mywebsearch.com|iwon.com|mysearch.com|search-results.com|dictionary.com|thesaurus.com|reference.com|improvenet.com

Change History (6)

comment:1 Changed 4 years ago by oleksandr

  • Component changed from Unknown to Adblock-Plus-for-Internet-Explorer
  • Platform changed from Unknown / Cross platform to Internet Explorer

comment:2 Changed 4 years ago by oleksandr

  • Blocked By 3237 added
  • Priority changed from Unknown to P2

Looks like the issue is very similar as in #3237. A fix for #3237 fixes this as well.

comment:3 Changed 4 years ago by oleksandr

  • Owner set to oleksandr
  • Ready set

comment:4 Changed 4 years ago by oleksandr

  • Milestone set to Adblock-Plus-for-Internet-Explorer-Next
  • Resolution set to fixed
  • Status changed from new to closed

comment:5 Changed 3 years ago by rraceanu

  • Tester changed from Unknown to Rraceanu

comment:6 Changed 3 years ago by rraceanu

  • Verified working set

Change successfully implemented, Whitelisted ads are shown with Easylist Germany+ Easylist and AA enabled on ask.com whilst doing a search query, IE 10 Windows 8 and IE 11 Windows 10, ABP version 1.5.856.

Last edited 3 years ago by rraceanu (previous) (diff)
Note: See TracTickets for help on using tickets.