Opened 4 years ago

Closed 3 years ago

#3369 closed defect (fixed)

Starting Adblock Browser causes pre-opened tabs to appear in the history again

Reported by: mario Assignee:
Priority: P4 Milestone: Adblock-Browser-for-iOS-1.3.0
Module: Adblock-Browser-for-iOS Keywords: salsita
Cc: Blocked By:
Blocking: Platform: Adblock Browser for iOS
Ready: yes Confidential: no
Tester: Scheer Verified working: yes
Review URL(s):

Description

Environment

iPhone 6
iOS 9.1
ABB 1.2.0 (any)

How to reproduce

  1. Open Adblock Browser
  2. Visit 3 websites (e.g. http://google.com/, http://adblockplus.org/, http://acceptableads.org/) each in a different tab.
  3. Close one of the tabs (e.g. http://acceptableads.com/ so only two tabs remain)
  4. Have a look at your browsing history and note that it contains those three websites visited under step 2.
  5. Close Adblock Browser and wait one day
  6. Open Adblock Browser (the next day)

Observed behaviour

When you have a look at the browsing history again the two remaining websites (see step 3.; http://google.com/ and http://adblockplus.org/) are listed as "visited today" even though they weren't actively visited. This only happens with websites that are still open in tabs while starting Adblock Browser.

Expected behaviour

The websites (see step 3.; http://google.com/ and http://adblockplus.org/) shouldn't appear as "visited today" but remain in the browsing history of the day before unless they're actively visited (i.e. opened again or actively browsed).
In other words: keeping websites in tabs shouldn't trigger a visit in the history on reopening the browser.

Change History (7)

comment:1 Changed 4 years ago by mario

  • Priority changed from Unknown to P4
  • Ready set

comment:3 Changed 4 years ago by jand

  • Resolution set to fixed
  • Status changed from new to closed

comment:4 Changed 4 years ago by mario

  • Milestone set to Adblock-Browser-for-iOS-next

comment:5 Changed 4 years ago by scheer

  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Tester changed from Unknown to Scheer

The issue here is that after restarting ABB after one full day of not using it, that any tabs that were previously open and not reloaded upon opening the app again still showed in the 'Today' History. Sadly, I am not able to check this, as currently there is now the issue that no History is shown after the first days History that is created.

So - Yesterday I left the device with History. The History section displayed the websites visited and was labelled as 'Today'. Upon returning today, the History is still shown and the day correctly shows 'Yesterday', but now, when visiting new sites, in existing and new tabs, there is no History logged at all.

Upon further inspection, it would appear that restarting the app will refresh the History and display it correctly.

ABB 1.3.0-qa (824)
iPhone 6 Plus - iOS 9.2.1

Last edited 3 years ago by scheer (previous) (diff)

comment:6 Changed 3 years ago by pavelz

We conclusively cannot reproduce it. It may be an effect of some specific webpage, not a general history saving malfunction. Is a specific webpage known?

comment:7 Changed 3 years ago by scheer

  • Resolution set to fixed
  • Status changed from reopened to closed
  • Verified working set
  • I was no longer able to reproduce that when visiting new sites, in existing and new tabs, there is no History logged at all after using a tab from a previous days history.

ABB 1.3.0-qa (844)
iPhone 6 Plus - iOS 9.2.1

Note: See TracTickets for help on using tickets.