Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#337 closed defect (fixed)

Race condition preventing initialization on first run

Reported by: trev Assignee: trev
Priority: P1 Milestone: Adblock-Plus-1.8-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: sebastian Blocked By:
Blocking: Platform:
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/5713134241185792/

Description

Environment

Chromium 28.0.1489.0 (196342). This might affect current Chrome versions as well sometimes but Chromium 28 is where we can reproduce this consistently.

How to reproduce

  1. Switch Chromium into developer mode and install Adblock Plus as unpacked extension from the devenv directory.

Observed behaviour

No first-run page appears and no subscriptions are added. This seems to be caused by a race condition - FilterStorage manages to initialize (call IO.statFile() and discover that patterns.ini is missing) before background.js gets a chance to add its listener for the load notification.

Expected behaviour

First-run page should appear and subscriptions should be added.

Change History (3)

comment:1 Changed 5 years ago by trev

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 5 years ago by trev

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:3 Changed 5 years ago by trev

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
Note: See TracTickets for help on using tickets.