Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#338 closed defect (fixed)

Adblock Plus isn't compatible with Chrome 19 anymore

Reported by: sebastian Assignee:
Priority: P2 Milestone: Adblock-Plus-1.8-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: trev, smultron45@… Blocked By:
Blocking: Platform:
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/6276084194607104/

Description

Currently we require Chrome >= 19 as given in by the generated manifest.json when installing Adblock Plus. However we rely on following API changes that were introduced later:

  • We use an object in order to configure browserAction icons for different sizes, which isn't possible before Chrome 23.
  • We rely on sender.url in the chrome.runtime.onMessage listener, which was first added in Chrome 28.

So we have to update the minimum compatible version to Chrome 28. And can completely remove legacy code for supporting older versions of Chrome.

Change History (5)

comment:1 Changed 6 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 6 years ago by mapx

  • Cc smultron45@… added

comment:3 Changed 6 years ago by sebastian

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:5 Changed 5 years ago by sebastian

  • Ready set
Note: See TracTickets for help on using tickets.