Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#339 closed defect (fixed)

Filter classes unit tests fail in Chrome

Reported by: trev Assignee: trev
Priority: P3 Milestone: Adblock-Plus-1.8-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: Blocked By:
Blocking: Platform:
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/4846749680140288

Description

How to reproduce

  1. Install Adblock Plus from development environment.
  2. Open Adblock Plus options, then replace options.html in the URL bar by qunit/index.html
  3. Inspect unit test results

Observed behaviour

Two unit tests fail, the invalid filters #dd(asd)(ddd) and #* don't list the reason why they are invalid.

Expected behaviour

All unit tests should succeed.

Change History (3)

comment:1 Changed 5 years ago by trev

  • Ready set
  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 5 years ago by trev

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:3 Changed 5 years ago by trev

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
Note: See TracTickets for help on using tickets.