Opened 22 months ago

Closed 20 months ago

Last modified 11 months ago

#3412 closed defect (invalid)

AdblockPlusEngine in current tip crashes on bing.com

Reported by: oleksandr Assignee:
Priority: P1 Milestone: Adblock-Plus-for-Internet-Explorer-1.6
Module: Adblock-Plus-for-Internet-Explorer Keywords: crash
Cc: oleksandr, sergz Blocked By:
Blocking: #1793 Platform: Internet Explorer
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by oleksandr)

Environment

ABP for IE revision: hg:b8a2dd6815c8
IE11, Enhanced Protected Mode on, 64-bit processes in EPM on.
Windows 10

How to reproduce

  1. Build adblockplusie debug build and make sure the newly built version is used by IE.
  2. In IE navigate to bing.com

Observed behaviour

Observe a debug error message box (- abort() has been called).

Expected behaviour

No error should be displayed.

It seems like the problem was introduced in hg:f1b046b7e0be with a fix for #1793

Change History (4)

comment:1 Changed 22 months ago by oleksandr

  • Description modified (diff)

comment:2 Changed 21 months ago by eric@…

http://bing.com loads fine for me in IE11, Protected Mode but not Enhanced Protected Mode, Windows 7

comment:3 Changed 20 months ago by oleksandr

  • Resolution set to invalid
  • Status changed from new to closed

Loading http://bing.com forces loading of 32-bit version of the plugin. In the test scenario above the 32-bit version was simply outdated comparing to the 64-bit build and the AdblockplusEngine version. Closing the ticket as invalid.

comment:4 Changed 11 months ago by oleksandr

  • Milestone set to Adblock-Plus-for-Internet-Explorer-Next
Note: See TracTickets for help on using tickets.