Opened 4 years ago

Closed 4 years ago

#3418 closed change (fixed)

Replace expression closures in prefs.js

Reported by: trev Assignee: trev
Priority: P3 Milestone:
Module: Automation Keywords:
Cc: sebastian Blocked By:
Blocking: #312, #1434 Platform: Firefox
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29332780/

Description

Background

prefs.js is currently causing warnings in Firefox nightly due to its use of expression closures.

What to change

Replace expression closures by arrow functions.

Change History (4)

comment:1 Changed 4 years ago by trev

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 4 years ago by sebastian

  • Cc sebastian added

Duplicate of #1434?

comment:3 Changed 4 years ago by sebastian

  • Blocking 312, 1434 added

Never mind. Let's get this landed, addressing the remaining non-standard JS in buildtools separately.

comment:4 Changed 4 years ago by trev

  • Resolution set to fixed
  • Status changed from reviewing to closed

Yes, #1434 is rather vague and most of this landed in smaller chunks already.

Fixed: https://hg.adblockplus.org/buildtools/rev/f3c4a535f1c7

Note: See TracTickets for help on using tickets.