Opened 5 years ago

Closed 3 years ago

#344 closed defect (fixed)

Issue reporter doesn't show any report data

Reported by: arthur Assignee: trev
Priority: P3 Milestone: Adblock-Plus-2.6.10-for-Firefox
Module: Adblock-Plus-for-Firefox Keywords:
Cc: trev Blocked By:
Blocking: Platform: Firefox
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

http://codereview.adblockplus.org/5205543194984448

Description

Environment

Firefox 28
Adblock Plus 2.5.1.3795
Windows 8.1 Pro x64 (Update 1)

How to reproduce

  1. Open any page like google.com
  2. Click the ABP icon and go to "Report issue on this page..."
  3. Choose "Other issue" and go to the next page
  4. Tick the checkbox and go to the next step
  5. Tick the checkbox to attch the screenshot and go to the next step
  6. Click on "Show report data"

Observed behaviour

The data isn't shown (see screenshot). Apparently a new panel opens but there is no way to see the actual data like scroll bars e. g.

Expected behaviour

The data should be visible.

Attachments (2)

show_report_data_issue reporter.png (18.0 KB) - added by arthur 5 years ago.
ReportDataField_Win7.png (4.4 KB) - added by Ross 4 years ago.

Download all attachments as: .zip

Change History (13)

Changed 5 years ago by arthur

comment:1 Changed 5 years ago by trev

  • Cc trev added

The text field is apparently too small on Windows 8.1. Nothing changed here on our end so I assume that it still works fine on Windows 7.

comment:2 Changed 5 years ago by trev

  • Owner set to trev
  • Status changed from new to assigned

comment:3 Changed 5 years ago by trev

  • Review URL(s) modified (diff)
  • Status changed from assigned to reviewing

comment:4 Changed 5 years ago by philll

Apparently, the field is just one line high in Win7 with FF 28 and ABP 2.5.1.3791

comment:5 follow-up: Changed 5 years ago by trev

  • Priority changed from P1 to P2

Reducing priority - this isn't essential functionality and it looks like the issue is limited to Windows 8. It's too late to have this fixed in Adblock Plus 2.6, this should be resolved after the release instead.

comment:6 in reply to: ↑ 5 Changed 5 years ago by arthur

Replying to trev:

Reducing priority - this isn't essential functionality and it looks like the issue is limited to Windows 8. It's too late to have this fixed in Adblock Plus 2.6, this should be resolved after the release instead.

Will this be resolved in 2.6.1?

comment:7 Changed 5 years ago by trev

No, it won't, still need to look into whether greiner's objections are valid.

comment:8 Changed 4 years ago by philll

  • Platform set to Firefox

comment:9 Changed 4 years ago by trev

  • Priority changed from P2 to P3

comment:10 Changed 4 years ago by Ross

As philll mentioned before, this also occurs in Windows 7 where the field is only one text line in height and not very usable/readable. Added screenshot.

Firefox 36 / Windows 7 x64

Firefox Build: 2.6.7.3911

Changed 4 years ago by Ross

comment:11 Changed 3 years ago by trev

  • Milestone set to Adblock-Plus-for-Firefox-next
  • Resolution set to fixed
  • Status changed from reviewing to closed
  • Tester set to Unknown
Note: See TracTickets for help on using tickets.