Opened 4 years ago

Closed 23 months ago

#3440 closed defect (rejected)

Browser hangs on many pages when Adblock Plus is installed

Reported by: PIGSgrame Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords:
Cc: kzar, mapx Blocked By:
Blocking: Platform: Firefox
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

Mozilla/5.0 (Windows NT 6.1; rv:44.0) Gecko/20100101 Firefox/44.0
Windows 7 Professional 32bit
Adblock Plus 2.7.0.4095-beta

How to reproduce

I will give an example that has already been posted at the forum by another user, but the issue happens on many other sites, even far more popular ones.

  1. Go to http://www.overclockers.ru/
  2. Let the page load fully, then scoll a few times, maybe click the reload button

Observed behaviour

After a few seconds, maybe after scrolling the page, the browser hangs and does not not react anymore. The only way to make it work again is to kill firefox.exe and restart the browser. Since this happens on many sites, the issue makes Firefox unuseable.

Expected behaviour

Ads should be blocked, but browser should still be responsive

Change History (1)

comment:1 Changed 23 months ago by kzar

  • Cc kzar mapx added
  • Component changed from Unknown to Platform
  • Resolution set to rejected
  • Status changed from new to closed

I can't reproduce this with Firefox 57 and Adblock Plus 3.0.2, closing this for now. If you're still having this problem please let me know how to reproduce and I'll reopen. Thanks, Dave.

Note: See TracTickets for help on using tickets.