Opened 4 years ago

Closed 4 years ago

#3452 closed change (fixed)

Bring back $ping type option

Reported by: trev Assignee: trev
Priority: P3 Milestone: Adblock-Plus-2.7.1-for-Firefox
Module: Adblock-Plus-for-Firefox Keywords:
Cc: sebastian Blocked By:
Blocking: Platform: Firefox
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29333043/
https://codereview.adblockplus.org/29333048/

Description (last modified by sebastian)

Background

The $ping option was removed because <a ping> functionality is still hidden behind a pref in Firefox, so requests of this type are an edge case.

However, by now navigator.sendBeacon() method was introduced which is essentially a generalization of the concept and is enabled by default.

Moreover, Chrome supports <a ping> by default. Starting with Chrome 49, requests caused by <a ping> and navigator.sendBeacon() will be reported through the chrome.webRequest API using the type ping.

What to change

Add $ping type option back and map TYPE_PING and TYPE_BEACON to it.

Change History (4)

comment:1 Changed 4 years ago by sebastian

  • Cc sebastian added

comment:2 Changed 4 years ago by sebastian

  • Description modified (diff)

comment:3 Changed 4 years ago by trev

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:4 Changed 4 years ago by trev

  • Milestone set to Adblock-Plus-for-Firefox-next
  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.