Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#3458 closed defect (fixed)

e10s changes broke popup blocking

Reported by: SMed79 Assignee: trev
Priority: P1 Milestone: Adblock-Plus-2.7.1-for-Firefox
Module: Adblock-Plus-for-Firefox Keywords:
Cc: trev, greiner, sebastian, mapx, arthur, erikvold Blocked By:
Blocking: Platform: Firefox
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29333141/

Description (last modified by mapx)

Environment

OS: Manjaro Linux, Debian Linux, Windows 10
Firefox 38,42,43, 44.0b4
ABP 2.7

How to reproduce

  1. Go to https://audioz.download/software/mac/
  2. Click anywhere.

Observed behaviour

Open popup to terraclicks.com and not closed despite the presence of filter | | terraclicks.com $ popup, third-party on EasyList.

Expected behaviour

No popup if we block ||audioz.download/other/$script

same issue:

  1. go to http://full-stream.org/6988-situation-amoureuse-cest-compliqu.html
  2. click @mail.ru, speedvideo, Netu.TV ... or the X icone.

POPUP to terraclicks.com not recognized.

Change History (15)

comment:1 Changed 3 years ago by mapx

  • Cc trev greiner sebastian mapx added

comment:2 Changed 3 years ago by sebastian

Reproduced with Firefox 38.0 and Adblock Plus 2.7.0.4099.
Not reproducible on Chrome 46.0.2490.71 with Adblock Plus 1.9.4.1508.

comment:3 Changed 3 years ago by arthur

  • Cc arthur added

Fyi: works as expected with ABP 2.6.11 on FF 43.0.2.

comment:4 Changed 3 years ago by sebastian

It's also already broken in Adblock Plus 2.6.12.4060. I'm testing on Firefox 42 now (latest version in Debian). However, for some reasons I cannot install builds of some older versions (anymore). Firefox is preventing these versions from installation with a rather bogus error message. This makes tracking down this bug not any easier. :(

Last edited 3 years ago by sebastian (previous) (diff)

comment:5 Changed 3 years ago by mapx

Did you already turned OFF (false)
xpinstall.signatures.required
?

comment:6 Changed 3 years ago by sebastian

  • Cc erikvold added
  • Component changed from Unknown to Adblock-Plus-for-Firefox
  • Platform changed from Unknown / Cross platform to Firefox
  • Priority changed from Unknown to P1
  • Ready set
  • Summary changed from POPUP not recognized to e10s changes broke popup blocking

Yes, xpinstall.signatures.required has been disabled. It's weird and seem to happen rather randomly. However, wiping the Firefox profile seems to help when it does.

So I was able to track down the bug to be a regression introduced by 32d16e3d1cb8. But I'm not too familar with the Gecko APIs used there. Since Wladimir is on vacation, I loop in Erik.

comment:7 Changed 3 years ago by sebastian

  • Summary changed from e10s changes broke popup blocking to e10s changes broke popup blocking (on Linux?)

comment:8 Changed 3 years ago by mapx

Linux ? I can reproduce the issue in windows 10

comment:9 Changed 3 years ago by sebastian

  • Description modified (diff)
  • Summary changed from e10s changes broke popup blocking (on Linux?) to e10s changes broke popup blocking

Well, before nobody confirmed that it's reproducible on other operating systems than Linux. But thanks for confirming that it in fact is also on Windows. I updated the issue.

comment:10 Changed 3 years ago by mapx

  • Description modified (diff)

comment:11 Changed 3 years ago by trev

This is reproducible reliably for me. Diagnostics shows that we only get about:blank as URL for this pop-up, never the final URL.

comment:12 Changed 3 years ago by trev

  • Owner set to trev

comment:13 Changed 3 years ago by trev

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:14 Changed 3 years ago by trev

  • Milestone set to Adblock-Plus-for-Firefox-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:15 Changed 3 years ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Popup blocking is working.

ABP 2.7.0.4128-beta
Firefox 38 / 43 / 44 / 45 / 46.0a1 / Ubuntu 14.04 x64

Note: See TracTickets for help on using tickets.