Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#3461 closed defect (fixed)

the issue reporter is broken

Reported by: mapx Assignee: trev
Priority: P1 Milestone: Adblock-Plus-2.7.1-for-Firefox
Module: Adblock-Plus-for-Firefox Keywords:
Cc: trev, erikvold, greiner, sebastian Blocked By:
Blocking: Platform: Firefox
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29333150/

Description (last modified by trev)

Environment

w 10
FF 44.0b4 (but also 43 as reported by users in forum)
with / without easylist
ABP 2.7

How to reproduce

or http://www.2700chess.com/live

  • click report issue on this page
  • choose "adblock plus is blocking too much"

Observed results

Only "Cancel" button is enabled, "back" and "next" are disabled.

Error Console shows:

TypeError: requests[i].filter.subscriptions is undefined sendReport.js:828:37

Background

This appears to be a regression from E10S-related changes to the RequestEntry data structure.

Change History (14)

comment:1 Changed 4 years ago by mapx

  • Description modified (diff)

comment:2 Changed 4 years ago by mapx

ABP 2.7.0.4103 seems to work fine

comment:3 Changed 4 years ago by sebastian

Well, if the issue is already fixed in the latest development build, feel free to close it as worksforme.

comment:4 Changed 4 years ago by mapx

  • Resolution set to worksforme
  • Status changed from new to closed

comment:5 Changed 4 years ago by sebastian

For reference, I couldn't even reproduce it with Firefox 42 and ABP 2.7 (stable).

comment:6 Changed 4 years ago by mapx

strange: other users reported the same issue (reporter broken in 2.7)

https://adblockplus.org/forum/viewtopic.php?f=1&t=43311

comment:7 Changed 4 years ago by trev

I created #3464, but I cannot tell whether it is identical to the issue reported here.

comment:8 Changed 4 years ago by trev

Note that #3464 merely describes the scenario I reproduced - there is plenty of other bug 1202902 breakage in the Issue Reporter.

comment:9 Changed 4 years ago by trev

  • Description modified (diff)
  • Ready set
  • Resolution worksforme deleted
  • Status changed from closed to reopened

Actually, I could reproduce this after fixing #3464 - not the same issue.

comment:10 Changed 4 years ago by trev

  • Owner set to trev

comment:11 Changed 4 years ago by trev

  • Priority changed from Unknown to P1

comment:12 Changed 4 years ago by trev

  • Review URL(s) modified (diff)
  • Status changed from reopened to reviewing

comment:13 Changed 4 years ago by trev

  • Milestone set to Adblock-Plus-for-Firefox-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:14 Changed 4 years ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Issue reporter including updating filters seems to be working correctly.

ABP 2.7.0.4128-beta
Firefox 38 / 43 / 44 / 46.0a1 / Ubuntu 14.04 x64

Note: See TracTickets for help on using tickets.