Opened 4 years ago

Closed 4 years ago

#3462 closed defect (invalid)

Add whitelist button does not have an id attribute

Reported by: Ross Assignee:
Priority: P3 Milestone:
Module: User-Interface Keywords:
Cc: greiner Blocked By:
Blocking: Platform: Chrome
Ready: no Confidential: no
Tester: Ross Verified working: no
Review URL(s):

Description

Environment

ABP 1.9.4.1504
Chrome 47.0.2526.80 / Ubuntu 14.04 x64

How to reproduce

  1. Open ABP options.
  2. Select the "Whitelisted domains" tab.
  3. [Right click] > [Inspect] the [Add domain] button.
  4. Observe it has no id attribute.
  5. [Right click] > [Inspect] the [Remove selected] button.
  6. Observe it does have an id attribute.

Observed behaviour

The [Add domain] button has no id attribute.

Expected behaviour

The [Add domain] button to have an id attribute since the [Remove selected] button has it already. ID's on "user action" elements are useful for automated tests since it allows them to know they found (or didn't) the right element, instead of looping over/through parents and possibly matching classes.

Change History (2)

comment:1 Changed 4 years ago by greiner

  • Cc greiner added
  • Component changed from Unknown to User-Interface

This button is only there to allow the user to submit the form. Therefore finding an element that matches button[type="submit"] should be sufficient (or button.addButton[type="submit"] if you want it to be more specific).

Is that sufficient?

comment:2 Changed 4 years ago by greiner

  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.