Opened 4 years ago

Closed 4 years ago

#3469 closed defect (invalid)

Blocking one modal box blocks the entire website and shows in dull colors

Reported by: passbrains Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords:
Cc: greiner Blocked By:
Blocking: Platform: Chrome
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by scheer)

Adapted from https://platform.passbrains.com/dashboard/view-ticket.php?ticket_no=ACH-239

Environment

ABP version 1.9.4.1508

How to reproduce

1.Open Chrome and enter Snapdeal.com
2.A Modal dialog box opens up
3.Now click on ABP and select Block element and select the Modal dialog to block it
4.Check in the ABP filters to verify that modal box is blocked
5.Check the website
6.Observe that the page is shown, but it appears as if Modal box is still present because of the grey back drop, but the box no longer appears.

Observed behaviour

The website appears´greyed out´as if the Modal box was still present,when it isn´t.

Expected behaviour

The website should be shown clearly and should not be in dull colors

Attachments (1)

13317_1451643935_Recording_266.mp4 (1.1 MB) - added by passbrains 4 years ago.

Download all attachments as: .zip

Change History (3)

Changed 4 years ago by passbrains

comment:1 Changed 4 years ago by scheer

  • Description modified (diff)

comment:2 Changed 4 years ago by greiner

  • Cc greiner added
  • Component changed from Unknown to Platform
  • Resolution set to invalid
  • Status changed from new to closed

This is a filter issue. Such dialogs usually consist of two parts: the dialog itself and the background. Both of those overlay the content and thereby hinder you from interacting with the site.

Therefore hiding the dialog itself doesn't do much. You also need to hide the background overlay to completely hide the modal dialog.

Note: See TracTickets for help on using tickets.