Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#3472 closed defect (fixed)

Block element option in icon popup not shown while page is loading

Reported by: passbrains Assignee: greiner
Priority: P3 Milestone: Adblock-Plus-1.10.1-for-Chrome-Opera-Safari
Module: User-Interface Keywords:
Cc: greiner Blocked By:
Blocking: Platform: Chrome
Ready: yes Confidential: no
Tester: Scheer Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29333344/

Description (last modified by greiner)

Adapted from https://platform.passbrains.com/dashboard/view-ticket.php?ticket_no=ACH-233

Environment

ABP version 1.9.3.1498

How to reproduce

  1. Open the URL "http://www.ibnlive.com/blog/" in Chrome
  2. Then click on select blogger option
  3. Click on ABP icon while page is loading
  4. Observe that ABP does not show the ´Block element´option

Observed behaviour

The block element option is not displayed in the icon popup.

Expected behaviour

The Block element option should be shown in the icon popup.

Background

When opening the icon popup it checks whether the code for selecting elements on the page is loaded and adds the "Block element" entry.

What to change

If the code for selecting elements on the page is not ready when opening the popup we should listen to when it is and add the "Block element" entry after the fact.

Attachments (2)

13317_1448973736_Noblock.jpg (265.6 KB) - added by passbrains 4 years ago.
13317_1448973736_Recording_81.mp4 (1.4 MB) - added by passbrains 4 years ago.

Download all attachments as: .zip

Change History (10)

Changed 4 years ago by passbrains

Changed 4 years ago by passbrains

comment:1 Changed 4 years ago by passbrains

1 - 14 Dec 2015 17:43:59 posted by Timo Scherf
Could not reproduce this issue.
Anyway your video makes it obvious that there was something wrong. This issue behaviour should be under supervision for the next builds.
Win 10 Chrome 47
ABP 1.9.4.1500

comment:2 Changed 4 years ago by scheer

  • Description modified (diff)
  • Summary changed from Cannot see Block element menu option when seeing Blogs to The ´block element´ option is not shown when ABP is selected after page load

I was able to reproduce this using the steps provided above on Chrome 47, WIN 10 ABP 1.10.0.

comment:3 Changed 4 years ago by greiner

  • Cc greiner added
  • Component changed from Unknown to User-Interface
  • Description modified (diff)
  • Ready set
  • Summary changed from The ´block element´ option is not shown when ABP is selected after page load to Block element option in icon popup not shown while page is loading

I was able to reproduce it. The issue occurs because the icon popup was opened before the page finished loading so I modified the description to reflect that.

comment:4 Changed 4 years ago by greiner

  • Priority changed from Unknown to P3

comment:5 Changed 4 years ago by greiner

  • Owner set to greiner

comment:6 Changed 4 years ago by greiner

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:7 Changed 4 years ago by greiner

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:8 Changed 4 years ago by scheer

  • Tester changed from Unknown to Scheer
  • Verified working set

Done. The Block Element feature now loads correctly.

Windows 10 64Bit / Chrome 47.0
ABP for Chrome / 1.10.0.1528

Note: See TracTickets for help on using tickets.