Changes between Version 3 and Version 6 of Ticket #3478


Ignore:
Timestamp:
01/06/2016 04:56:27 PM (4 years ago)
Author:
sebastian
Comment:

https://hg.adblockplus.org/adblockplus/rev/c6c06dd1b482

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #3478

    • Property Status changed from reviewing to closed
    • Property Cc trev added; trevgeneric removed
    • Property Summary changed from genericblock and generichide aren't disabled in the composer for blocking filters to Hide genericblock and generichide types in the composer
    • Property Priority changed from Unknown to P4
    • Property Milestone changed from to Adblock-Plus-for-Firefox-next
    • Property Ready set
    • Property Resolution changed from to fixed
  • Ticket #3478 – Description

    v3 v6  
    66 
    77=== Observed behaviour === 
    8 While the `document` is disabled (for non-whitelist filters), `genericblock` and `generichide` can still be selected. These options however doesn't make any sense there either, since they are only allowed in exception rules. 
     8While the `document` is disabled (for non-whitelist filters), and `elemhide` isn't even exposed, `genericblock` and `generichide` can still be selected. 
    99 
    1010=== Expected behaviour === 
    11 Disable the `genericblock` and `generichide` for non-whitelist filters, same as for `document`.  
     11Hide the `genericblock` and `generichide` types in the composer, same like `elemhide`.