Opened 4 years ago

Closed 21 months ago

#3484 closed defect (rejected)

Testcase CF-3 Step 11 Build: #3956: "First hiding filter was applied" message appears instead of "Second hiding filter was applied" message

Reported by: passbrains Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: Ross, kzar Blocked By:
Blocking: Platform: Firefox
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by scheer)

Adapted from https://platform.passbrains.com/dashboard/view-ticket.php?ticket_no=ARE-161

Environment

Windows + 8.1 64bit + Firefox + English
ABP version ABP build 2.6.9.3956

How to reproduce

  1. With Firefox, select [ABP Icon] > [Filter preferences...]
  2. Select the [Custom filters] tab if it's not already focused
  3. Select [Add filter group]
  4. Enter 'Test Filters' as the name and press the [ENTER] key
  5. If hidden, expand the right hand side of the window using the splitter control on the right
  6. Select the [Add filter] button on the right hand side
  7. Enter '##.abp-test-hiding-filter-top' (with no quotes) and press the [ENTER] key.
  8. Select the [Add filter] button on the right hand side
  9. Enter '##.abp-test-hiding-filter' (with no quotes) and press the [ENTER] key.
  10. Select [Close] to close the options window
  11. Navigate to https://testpages.adblockplus.org/en/testsuite/07
  12. Check the instructions and the result of the test case on the page

Observed behaviour

"First hiding filter was applied" message appears instead of "Second hiding filter was applied" message.

Expected behaviour

The page should report 'Second hiding filter detected'.

Attachments (3)

2315_1435839225_2015-07-02_15-07-34.mp4 (2.9 MB) - added by passbrains 4 years ago.
2315_1435839225_2015-07-02_15-12-52.png (138.2 KB) - added by passbrains 4 years ago.
Capture.PNG (287.6 KB) - added by scheer 4 years ago.

Download all attachments as: .zip

Change History (6)

Changed 4 years ago by passbrains

Changed 4 years ago by passbrains

comment:1 follow-up: Changed 4 years ago by passbrains

1 - 08 Nov 2015 15:01:54 posted by Timo Scherf
Reproduced / still existing
ABP 2.6.11.4010
Firefox Dev Edition 44.0a2
Win 7 64 bit

2 - 07 Jan 2016 14:13:30 posted by Scott Cheer
This appears to be because the Classes in the page do not match the requested test case steps sequence. Please see highlighted section on added screenshot.

Changed 4 years ago by scheer

comment:2 Changed 4 years ago by scheer

  • Cc Ross added
  • Description modified (diff)

comment:3 in reply to: ↑ 1 Changed 21 months ago by kzar

  • Cc kzar added
  • Resolution set to rejected
  • Status changed from new to closed

Replying to Scott Cheer:

This appears to be because the Classes in the page do not match the requested test case steps sequence. Please see highlighted section on added screenshot.

It's not clear how to reproduce this issue and from the sounds of it there was a problem with the testpage itself. I'm closing this for now, let me know how to reproduce if you think it's still a problem.

Note: See TracTickets for help on using tickets.