Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#3491 closed defect (fixed)

Image preview in blockable items tooltip no longer works

Reported by: trev Assignee: trev
Priority: P1 Milestone: Adblock-Plus-2.7.1-for-Firefox
Module: Adblock-Plus-for-Firefox Keywords: e10s
Cc: Blocked By:
Blocking: #3259 Platform: Firefox
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29333327/

Description (last modified by trev)

Environment

Adblock Plus 2.7.0.4115-beta

How to reproduce

  1. Go to heise.de
  2. Click ABP icon and choose "Open blockable items"
  3. Hover the entries for some of the images illustrating the articles (located in the q50/imgs directory right now).

Observed behaviour

None of the images are displayed in tooltip. Error message "TypeError: content is null" shows up in Browser Console.

Expected behaviour

Some of the images are displayed in tooltip (the ones that aren't background images).

Background

This is a regression from #3259, the check whether the image is stored in cache fails.

Hints for testers

Turns out, this feature wasn't working correctly in the first place (ever since Firefox 32). The idea is that the image preview is only shown if the image is already in cache - there should be no network request, for privacy reasons. This simplest way to test this should be clearing the cache, opening the page in a private browsing window and opening blockable items there. No previews should show up because private browsing doesn't fill the regular cache. However, if you open the same page in regular mode and go back to your private browsing window the previews should show up.

Change History (6)

comment:1 Changed 4 years ago by trev

  • Keywords e10s added

comment:2 Changed 4 years ago by trev

  • Owner set to trev
  • Priority changed from P3 to P1

comment:3 Changed 4 years ago by trev

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:4 Changed 4 years ago by trev

  • Description modified (diff)

comment:5 Changed 4 years ago by trev

  • Milestone set to Adblock-Plus-for-Firefox-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:6 Changed 4 years ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Images in tooltips are now working as described (including private browsing/cache behaviour).

ABP 2.7.0.4128-beta
Firefox 38 / 43 / 44 / 46.0a1 / Ubuntu 14.04 x64

Note: See TracTickets for help on using tickets.