Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#3493 closed defect (invalid)

The word Chrome shows in the url ABP First Run Page of Firefox

Reported by: passbrains Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: greiner Blocked By:
Blocking: Platform: Firefox
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by greiner)

Adapted from https://platform.passbrains.com/dashboard/view-ticket.php?ticket_no=ARE-167

Environment

Windows + 8.1 64bit + Firefox + English
ABP version 2.6.9.3962

How to reproduce

  1. With Firefox, navigate to the .XPI file at "https://adblockplus.org/devbuilds/adblockplus/00latest.xpi".0006
  2. Select the [Install Now] button in the 'Software Installation' window.
  3. The ABP First Run Page is opened after installation.
  4. Note that the url contains Chrome instead of Firefox.

chrome://adblockplus/content/ui/firstRun.html

Observed behaviour

The url of ABP First Run Page contains "chrome".

Expected behaviour

The url of ABP First Run Page should contain "Firefox".

Attachments (1)

5162_1437533973_chrome-in-url-of-firefox.doc (185.5 KB) - added by passbrains 4 years ago.

Download all attachments as: .zip

Change History (4)

Changed 4 years ago by passbrains

comment:1 Changed 4 years ago by passbrains

1 - 08 Jan 2016 11:07:27 posted by Scott Cheer
Reproduced on Win 10 FF 43.0 ABP 2.7.

comment:2 Changed 4 years ago by greiner

  • Description modified (diff)
  • Resolution set to invalid
  • Status changed from new to closed

The word "chrome" in chrome://adblockplus/content/ui/firstRun.html refers to the browser's chrome which is a specific part of the browser UI (the one that contains toolbars, the addressbar, etc.). Google Chrome, on the other hand, originates from that because one of its goals was to minimize the space the chrome was occupying on the screen.

So chrome:// URLs in Firefox have nothing to do with the Chrome browser. They refer to browser-internal resources such as the browser's chrome itself which you can find at chrome://browser/content/browser.xul

comment:3 Changed 4 years ago by greiner

  • Cc greiner added
Note: See TracTickets for help on using tickets.