Opened 4 years ago

Closed 4 years ago

Last modified 5 weeks ago

#3496 closed defect (worksforme)

"block element" doesn't work on http://www.flvto.biz/

Reported by: mapx Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords:
Cc: sebastian, greiner, kzar Blocked By:
Blocking: Platform: Chrome
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

w10
chrome Version 48.0.2564.71 beta-m (64-bit)
ABP 1.10.0.1514
easylist

How to reproduce

go to http://www.flvto.biz/

  • first issue

click ABP icon, "block element"
nothing can be selected (highlighted) in that page

  • second issue

right click the ad at the top (JoyGames)
choose "block element"
nothing happens
the image it's of this type:
<img src="data:image/jpeg;base64

Change History (8)

comment:1 Changed 4 years ago by mapx

other issues which could have the same root
#2653, #2740, #2753, #3138

comment:2 Changed 4 years ago by greiner

1) I was able to select the overlaying DIV element that opens an ad when clicking on it. After that elements on the page can be selected as usual. Therefore hiding that transparent overlay via a filter should resolve this issue.

2) The hiding works for me but only for this one specific image. Using the filter flvto.biz##img[src^="data:image/jpeg;base64,"] I was able to hide each of those.

Note that both examples seem to randomize the element's class name so you may want to use the newly introduced CSS property filters for that.

comment:3 Changed 4 years ago by mapx

weird, with the last filters, all it's fine now ...
https://hg.adblockplus.org/easylist/rev/b82d102c44e2

before this last fix I wasnt able to select something on the page (perhaps it was the overlay you're talking about)

comment:4 Changed 4 years ago by mapx

  • Resolution set to worksforme
  • Status changed from new to closed

comment:5 Changed 11 months ago by youtube2video

spam

Last edited 5 weeks ago by kzar (previous) (diff)

comment:6 in reply to: ↑ description Changed 11 months ago by youtube2video

spam

Last edited 5 weeks ago by kzar (previous) (diff)

comment:7 Changed 8 months ago by stevenfbtube

spam

Last edited 5 weeks ago by kzar (previous) (diff)

comment:8 Changed 4 months ago by akshaytrank

spam

Last edited 5 weeks ago by kzar (previous) (diff)
Note: See TracTickets for help on using tickets.