Opened 4 years ago

Closed 4 years ago

#3500 closed defect (worksforme)

"Add filters" dialog box length is too long for a website.

Reported by: passbrains Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords:
Cc: greiner, sebastian, kzar Blocked By:
Blocking: Platform: Opera
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by scheer)

Adapted from https://platform.passbrains.com/dashboard/view-ticket.php?ticket_no=AOP-225

Environment

Windows + 8 64bit + Opera + English
ABP version 1.8.12.1433

How to reproduce

  1. Install ABP.
  2. Open http://www.phoenixmarketcitybangalore.com
  3. Click ABP icon and click on 'Block element'. Select an element to be blocked. 
  4. Observe the ´Add Filter´ window is stretched accross the browser.

Observed behaviour

"Add filters" dialog box length is too long.

Expected behaviour

"Add filters" dialog box length is normal.

Attachments (1)

3766_1433007431_operaPhoenix.png (634.6 KB) - added by passbrains 4 years ago.

Download all attachments as: .zip

Change History (8)

Changed 4 years ago by passbrains

comment:1 Changed 4 years ago by passbrains

1 - 12 Jan 2016 09:36:12 posted by Scott Cheer
Still occurring on Opera 30.0 ABP 1.10.

comment:2 Changed 4 years ago by scheer

  • Description modified (diff)

comment:3 Changed 4 years ago by greiner

  • Component changed from Unknown to Platform

This issue occurs because the site's CSS (shown below) overrides our iFrame's width causing it to stretch to 100%.

iframe {
    width: 100% !important;
    margin: 0 !important;
    padding: 0 !important;
    border: 0 !important;
    max-width: 100% !important;
    overflow-y: hidden !important
}

comment:4 Changed 4 years ago by greiner

  • Cc greiner added

comment:5 Changed 4 years ago by sebastian

  • Cc sebastian kzar added

Perhaps just another reason to use a popup rather than injecting an <iframe>. See #2426.

comment:6 Changed 4 years ago by kzar

Yea, I agree.

comment:7 Changed 4 years ago by sebastian

  • Resolution set to worksforme
  • Status changed from new to closed

As the "Block element" dialog is now shown as popup (#2426), this issue became obsolete.

Note: See TracTickets for help on using tickets.