Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#3504 closed defect (fixed)

Screenshot color reduction step of the Issue Reporter is very slow

Reported by: trev Assignee: trev
Priority: P1 Milestone: Adblock-Plus-2.7.1-for-Firefox
Module: Adblock-Plus-for-Firefox Keywords:
Cc: Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29333406/

Description (last modified by trev)

Environment

Adblock Plus 2.7.0.4123-beta, Firefox 46.0a1 nightly

How to reproduce

  1. Click ABP icon and "Report issue on this page" on some website.

Observed behaviour

Data collection hangs on a single step (screenshot color reduction), it takes 30 seconds to get past that.

Expected behaviour

Data collection shouldn't take that long.

Background

Going through a few million pixels doesn't take that much time. However, my testing revealed that accessing pixelData.data is very slow - caching that value causes the processing time to drop from 30 seconds to 3.5 seconds. I'm not sure why it only shows now, might be caused by some changes in Firefox and not on our end.

Change History (5)

comment:1 Changed 4 years ago by trev

  • Description modified (diff)
  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 4 years ago by trev

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:3 Changed 4 years ago by trev

  • Milestone set to Adblock-Plus-for-Firefox-next

comment:4 Changed 4 years ago by trev

  • Component changed from Unknown to Adblock-Plus-for-Firefox

comment:5 Changed 4 years ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

No large delay noticed when processing screenshots.

ABP 2.7.0.4128-beta
Firefox 38 / 43 / 44 / 46.0a1 / Ubuntu 14.04 x64

Note: See TracTickets for help on using tickets.