Opened 4 years ago

Closed 20 months ago

#3519 closed defect (rejected)

After extending Edit Filters list, Apply changes button overlaps filter's name

Reported by: passbrains Assignee:
Priority: P5 Milestone:
Module: User-Interface Keywords: goodfirstbug
Cc: greiner Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by greiner)

Adapted from https://platform.passbrains.com/dashboard/view-ticket.php?ticket_no=ASA-51

Environment

Mac + OS X 10.7 + Safari + English
ABP version 1.8.12.1407

How to reproduce

  1. Install ABP extension on Safari
  2. Click ABP button
  3. Click Options
  4. Select Add your own filters tab
  5. Add any filter
  6. Click "Edit filters as raw text" link
  7. Now click left bottom corner in opened field and drag it to the right
  8. Observe Apply Changes button

Observed behaviour

After extending Edit Filters list, Apply changes button overlaps filter's name.

Expected behaviour

Apply changes button should not overlap filter's name. It should appear from the right side of Edit filters field.

What to change

Make the following changes to the options page's "Add custom filter" tab:

  • Remove width: 500px from any element in the table and replace it with width: 100%
  • Apply width: 500px on first column using <col>
  • Apply box-sizing: border-box on input, select and textarea elements to ensure that all have the same width

Attachments (2)

2315_1428156084_2015-04-04_16461.png (159.6 KB) - added by passbrains 4 years ago.
2315_1428156084_2015-04-04_1646.png (158.1 KB) - added by passbrains 4 years ago.

Download all attachments as: .zip

Change History (7)

Changed 4 years ago by passbrains

Changed 4 years ago by passbrains

comment:1 Changed 4 years ago by passbrains

1 - 15 Jan 2016 07:44:41 posted by Scott Cheer
Reproduced on Safari 8.0.6.

comment:2 Changed 4 years ago by greiner

  • Cc greiner added
  • Component changed from Unknown to User-Interface
  • Description modified (diff)
  • Platform changed from Safari to Unknown / Cross platform
  • Priority changed from Unknown to P4

Note that this is a browser feature you're referring to. It's not part of Adblock Plus which is why people should expect things to break when using it.

comment:3 Changed 4 years ago by greiner

  • Description modified (diff)
  • Keywords goodfirstbug added
  • Ready set

comment:4 Changed 2 years ago by greiner

  • Priority changed from P4 to P5

This ticket will soon no longer be relevant since we're going to replace the entire options page. Therefore I'm decreasing its priority for now.

comment:5 Changed 20 months ago by sebastian

  • Resolution set to rejected
  • Status changed from new to closed

This issue was filed for Safari, which we no longer active develop Adblock Plus for, hence won't port the new options page to. But it's probably not worth either to fix minor issues like this for the old options page in the safari branch.

Note: See TracTickets for help on using tickets.