Opened 4 years ago

Closed 4 years ago

#3520 closed defect (invalid)

Last installed version number of ABP is shown on newer installed version in Safari

Reported by: passbrains Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords: externaldependency
Cc: sebastian, scheer Blocked By:
Blocking: Platform: Safari
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by scheer)

Adapted from https://platform.passbrains.com/dashboard/view-ticket.php?ticket_no=ASA-57

Environment

Mac + OS X 10.10 + Safari + Deutsch - German
ABP version 1.8.12.1411

How to reproduce

Use most recent build of MacOs Yosemite (Version 10.10.3) including Safari Version 8.0.5

When using an older versions of Safari (build 8.0 or 8.03) this problem doesn't occur.

  1. Install a version from the Development page and record the version number
  2. Check that ABP is there and functioning
  3. Uninstall that version
  4. Download another development build version
  5. Observe that the development build number is not the new version number, but the number from the previous insallation

Observed behaviour

An old ABP build ID is displayed instead of the installed one -> see screen capture

Expected behaviour

Correct ABP build ID should be displayed after the new installation.

Attachments (1)

7240_1428915734_ABP.mov (9.2 MB) - added by passbrains 4 years ago.

Download all attachments as: .zip

Change History (7)

Changed 4 years ago by passbrains

comment:1 Changed 4 years ago by scheer

  • Description modified (diff)
  • Summary changed from Safari build 8.0.5 shows wrong build ID of ABP to Last installed version number of ABP is shown on newer installed version in Safari

comment:2 Changed 4 years ago by scheer

Reproduced in Yosemite 10.10.3, Safari 8.0.6.

comment:3 Changed 4 years ago by sebastian

  • Cc sebastian scheer added

Does that happen with other extensions as Adblock Plus as well?

If so it's a Safari bug, to be reported here.

comment:4 Changed 4 years ago by scheer

  • Resolution set to invalid
  • Status changed from new to closed

This seems to be intermittent with other extensions, however it does occur for them, which would imply that it is a Safari issue.

comment:5 Changed 4 years ago by scheer

  • Keywords externaldependency added
  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:6 Changed 4 years ago by sebastian

  • Resolution set to invalid
  • Status changed from reopened to closed

There is no point in leaving this issue open if there is nothing we can do. (Other open issues with externaldependency keyword require some changes on our end, once it has been addressed upstream. That's not the case here.)

Note: See TracTickets for help on using tickets.