Opened 4 years ago

Closed 2 years ago

#3531 closed defect (rejected)

iOS 8.0.* crash on startup

Reported by: pavelz Assignee:
Priority: P4 Milestone:
Module: Adblock-Browser-for-iOS Keywords: blocked
Cc: mario Blocked By:
Blocking: Platform: Adblock Browser for iOS
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

The app crash right on start.

Environment

ABB any version on iOS 8.0.* (NOT 8.1+ !!!)

How to reproduce

No known reproduction. Related HA report
https://rink.hockeyapp.net/manage/apps/185237/app_versions/42/crash_reasons/99888134

Change History (9)

comment:1 Changed 4 years ago by pavelz

Crash report description:

Terminating app due to uncaught exception 'NSInternalInconsistencyException', reason: 'scaledValueForValue: called on a font that doesn't have a text style set'

Related evidence
http://stackoverflow.com/questions/25773661/scaledvalueforvalue-called-on-a-font-that-doesnt-have-a-text-style-set

Custom fonts have a known issue on iOS 8.0.* which was fixed on iOS 8.1
The only possible solution is NOT to use custom fonts AT ALL when iOS 8.0.* is detected.

comment:2 Changed 4 years ago by mario

  • Priority changed from P2 to P4

Changed priority as not many users are affected by this.

comment:3 Changed 3 years ago by pavelz

@mario are we going to keep this in queue? Mind that it's just 8.0 not 8.1 so the potential victim would have to not just insist on iOS8, but also refusing to update it to the latest available version of iOS8. It practically disappeared in time of 1.5.0 - only 10 crashes since release (less than 1 crash/day).
https://rink.hockeyapp.net/manage/apps/310687/app_versions/26/crash_reasons/136469052

comment:4 Changed 3 years ago by pavelz

Alternative mitigation proposed by @mario: don't fix but hook on crash reporting on the next app start
https://www.hockeyapp.net/help/sdk/ios/4.1.1/docs/docs/HowTo-Set-Custom-AlertViewHandler.html
and display a generic alert there, asking the user politely to please update at least to latest 8.4 if not a newer iOS version.

comment:6 Changed 3 years ago by pavelz

  • Keywords blocked added

Statistics: 0.7-0.8 crashes per day, iOS 8.0.0 and 8.0.2 only. Please decide whether to throw the issue away completely or implement the upgrade begging per comment 4. Marking blocked.

comment:7 Changed 3 years ago by mario

As this issue – even though a minor one – still persists, let's keep it open at a low priority. Right at the moment, there's no reason to act upon this.

comment:8 Changed 2 years ago by ashephard

Would this be necessary now that we've switched the deployment target to 9.3?

comment:9 Changed 2 years ago by mario

  • Resolution set to rejected
  • Status changed from new to closed

No, this is indeed not relevant anymore. Closing.

Note: See TracTickets for help on using tickets.