Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#3533 closed defect (fixed)

History.pushState() doesn't work.

Reported by: mario Assignee:
Priority: P2 Milestone: Adblock-Browser-for-iOS-1.3.0
Module: Adblock-Browser-for-iOS Keywords: salsita
Cc: Blocked By:
Blocking: Platform: Adblock Browser for iOS
Ready: yes Confidential: no
Tester: Scheer Verified working: yes
Review URL(s):

Description (last modified by mario)

Environment

ABB 1.2.1
iPhone 6
iOS 9.2

How to reproduce

  1. Open ABB and navigate to http://html5demos.com/history
  2. Tap on the Link called "first"

Observed behaviour

Expected behaviour

Remark for testers

Please not that this issue originally consisted of two bugs (so please ignore the comments 1-5). Due to complexity the second bug has been removed from the scope of this very issue and divided into two new issues: #3553, #3554. The bug as described above has been fixed.

Change History (9)

comment:1 Changed 4 years ago by mario

Upon further investigation it seems like ABB still recognized the new URI state. When browsing the linked demo, tapping "first" and then reloading the page, ABB tries to reload "​http://html5demos.com/history/first" instead of "​http://html5demos.com/history", which is correct. So it seems like it just forgets to update the displayed URL.
Still navigating back and forth doesn't update the URI and shows a blank page instead.

comment:2 Changed 4 years ago by mario

  • Priority changed from Unknown to P2

Changed to P2. This affects websites like YouTube and Twitter.

comment:3 Changed 4 years ago by pavelz

Not updating the displayed URL confirmed. Can't reproduce the blank page however. It lands correctly on previous page (or dashboard page if html5demos was the first page loaded to that tab).

comment:4 Changed 4 years ago by mario

  • Description modified (diff)

I've updated the description. I've just discovered that the blank page is only shown if you navigate back using swipe gestures. Doesn't happen by using the back button.

comment:5 Changed 4 years ago by pavelz

The issue was partially fixed - to the scope of near-release reasonability. What works now:

  1. pushState is propagated completely and correctly to the browser backend, which means that URL is updated as expected when CREATING a new HTML5 history - even virtual nonexistent URLs like the one described in test
  2. swiping navigation updates the state of bacl/fwd buttons which it didn't previously (a related unreported bug)

What still does not work and has new issues spin off:

comment:6 Changed 4 years ago by pavelz

  • Resolution set to fixed
  • Status changed from new to closed

comment:7 Changed 4 years ago by mario

  • Description modified (diff)
  • Ready set

Changed the scope of the issue as part of it has been filed as separate issues.

comment:8 Changed 4 years ago by mario

  • Milestone set to Adblock-Browser-for-iOS-next

Batch modify: added Adblock-Browser-for-iOS-next milestone.

comment:9 Changed 4 years ago by scheer

  • Tester changed from Unknown to Scheer
  • Verified working set

ABP 1.3.0-qa (824)
iPhone 6S 16GB - iOS 9.2

Note: See TracTickets for help on using tickets.