Opened 4 years ago

Closed 16 months ago

#3535 closed defect (rejected)

All JS links on "Adblock Plus has been installed" page stop function if click Contributor Credits link and then click Back browser button

Reported by: passbrains Assignee:
Priority: P4 Milestone:
Module: User-Interface Keywords:
Cc: greiner Blocked By:
Blocking: Platform: Safari
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by greiner)

Adapted from https://platform.passbrains.com/dashboard/view-ticket.php?ticket_no=ASA-61

Environment

Mac + OS X 10.7 + Safari + English
ABP version 1.8.12.1423

How to reproduce

  1. Install ABP Safari extension
  2. When "Adblock Plus has been installed" page opens, do not click any other buttons apart from the 'Contributor Credits' link.
  3. When Contributor Credits page opens click back browser button
  4. When "Adblock Plus has been installed" page opens click Facebook, Twitter or Google + button in Tell your friends section

Observed behaviour

All JS links on "Adblock Plus has been installed" page stop functioning if click Contributor Credits link and then click Back browser button.
Following functionality stop function with this scenario:

  • disable link
  • Facebook, Twitter, Google + buttons in Tell your friends section
  • All toggles in Adblock Plus can do more than block ads section

Expected behaviour

All JS functionality should continue function after navigate to Contributor Credits page and then back to "Adblock Plus has been installed" page.

Background

It seems that the page is not being reloaded properly (e.g. "DOMContentLoaded" event does not get fired) when navigating back to it via the back button. There are a couple of reports of people encountering the same issue (e.g. jQuery) blaming it on the BFCache.

Since the suggested "pageshow" event is equivalent to the "load" event, it's getting fired later than the "DOMContentLoaded" event so we should use both to ensure that the page is being initialized as early as possible.

What to change

Add a listener for the "pageshow" event to initialize the page in case "DOMContentLoaded" was not fired.

Attachments (2)

2315_1430816347_2015-05-05_1157.png (326.6 KB) - added by passbrains 4 years ago.
2315_1430816348_Screen_Recording_18.mov (4.8 MB) - added by passbrains 4 years ago.

Download all attachments as: .zip

Change History (9)

Changed 4 years ago by passbrains

Changed 4 years ago by passbrains

comment:1 Changed 4 years ago by passbrains

1 - 29 Jun 2015 11:11:37 posted by Timo Scherf
Reproduced as described with build #1458

comment:2 Changed 4 years ago by scheer

  • Description modified (diff)

comment:3 Changed 4 years ago by scheer

I reproduced this, but I found that it only occurs if the user does not select one of the buttons as mentioned above before selecting the Contributor Credits page.

Reproduced on OS X 10.10.3 Safari 8.0.6 ABP 1.10.

comment:4 Changed 4 years ago by scheer

  • Description modified (diff)

comment:5 Changed 4 years ago by greiner

  • Cc greiner added
  • Component changed from Unknown to User-Interface
  • Description modified (diff)
  • Priority changed from Unknown to P3
  • Ready set

comment:6 Changed 2 years ago by sebastian

  • Priority changed from P3 to P4

comment:7 Changed 16 months ago by greiner

  • Resolution set to rejected
  • Status changed from new to closed

Closing this ticket because we're going to remove this link with the next iteration of the first-run page and Apple is ending support for Safari extensions in favor of content blocking apps.

Note: See TracTickets for help on using tickets.