Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#3541 closed defect (fixed)

Size of DOM Inspector dialogs is wrong first time they are opened

Reported by: trev Assignee: trev
Priority: P1 Milestone: Adblock-Plus-2.7.2-for-Firefox
Module: Adblock-Plus-for-Firefox Keywords:
Cc: Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29336300/

Description

Environment

Adblock Plus 2.7.1 (started with Adblock Plus 2.7 according to user report), Firefox 43, Mac OS X 10.11

Also reproducible in Firefox 46.0a1 nightly with multi-process switched off (DOM Inspector doesn't support E10S).

How to reproduce

  1. Install DOM Inspector 2.0.16: https://addons.mozilla.org/addon/dom-inspector-6622/
  2. On any web page go to menu Tools / Web Developer / DOM Inspector (alternatively you can customize your toolbar and drag the Web Developer menu into it).
  3. Press Cmd/Ctrl+F to open the Find Nodes dialog, dismiss it.
  4. Select an element and double-click an attribute in the right pane to edit it.

Observed behaviour

The dialogs open with buttons only, the content is missing. Second time they are opened correctly however.

Expected behaviour

The dialogs open correctly

Attachments (1)

testpolicy-1.0.xpi (2.1 KB) - added by trev 4 years ago.
Minimal extension reproducing the issue

Download all attachments as: .zip

Change History (8)

Changed 4 years ago by trev

Minimal extension reproducing the issue

comment:1 Changed 4 years ago by trev

I added a minimal extension to reproduce this issue without Adblock Plus. Turns out accessing document.documentElement from nsIContentPolicy.shouldLoad is sufficient to trigger this issue (content policy is called only once per session to check chrome://inspector/skin/inspector.css stylesheet).

comment:2 Changed 4 years ago by trev

  • Resolution set to invalid
  • Status changed from new to closed

This appears to be the same as https://bugzilla.mozilla.org/show_bug.cgi?id=1127744 - a platform issue, up to Mozilla to figure out what's going on here.

comment:3 Changed 4 years ago by trev

  • Priority changed from P3 to P1
  • Resolution invalid deleted
  • Status changed from closed to reopened

I realized that there is a simple work-around for this issue, reopening.

comment:4 Changed 4 years ago by trev

  • Owner set to trev

comment:5 Changed 4 years ago by trev

  • Review URL(s) modified (diff)
  • Status changed from reopened to reviewing

comment:6 Changed 4 years ago by trev

  • Milestone set to Adblock-Plus-for-Firefox-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:7 Changed 4 years ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Could not reproduce the issue demonstrated by the attachment.

ABP 2.7.2
Firefox 47.0a1 (Nightly) / OS X 10.11.3 x64

Note: See TracTickets for help on using tickets.