Opened 4 years ago

Closed 4 years ago

#3552 closed defect (fixed)

Increase Nginx header buffer size

Reported by: matze Assignee: matze
Priority: P2 Milestone:
Module: Infrastructure Keywords:
Cc: fred, fhd Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29334179

Description

Cloning https://hg.adblockplus.org/adblockbrowser fails with an HTTP 400 BAD REQUEST status. Analysis has shown that the cause is a common Mercurial issue, triggered by ?cmd=getbundle requests when too many heads have to be reported to the server. One can work around this symptom by increasing the HTTP daemons header buffer size. Selenic recommends a header buffer size of at least 16k under Windows/IIS, so we should adopt this recommendation for our Nginx setup.

Change History (2)

comment:1 Changed 4 years ago by matze

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 4 years ago by matze

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.