Opened 3 years ago

Closed 3 years ago

#3569 closed defect (worksforme)

www.nytimes.com site load speed is significantly lower and "TIMESVIDEO" section doesn't load on the main page when ABP is enabled on this site

Reported by: passbrains Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords:
Cc: kzar, scheer, arthur Blocked By:
Blocking: Platform: Safari
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by kzar)

Adapted from https://platform.passbrains.com/dashboard/view-ticket.php?ticket_no=ASA-81

Environment

Mac + OS X 10.7 + Safari + English
ABP version 1.9.4.1500

How to reproduce

  1. Install ABP 1.9.4.1500 build

 

  1. Make sure you have only one EasyList subscription enabled
  2. Make sure you have no filters on "Add your own filters" tab
  3. Load www.nytimes.com  site page
  4. Wait until it loads and check loading time
  5. When site is loaded check if "TIMESVIDEO" section is loaded

Observed behaviour

www.nytimes.com site load speed is significantly lower and "TIMESVIDEO" section doesn't load on the main page when ABP is enabled on this site.
With ABP enabled www.nytimes.com site loads 51 seconds.
With ABP disabled www.nytimes.com site loads 5 seconds.
Own filters list is empty. There is only one enabled subscription (EasyList) on Filters list tab.

Expected behaviour

www.nytimes.com page should be loaded in decent amount of the time.
"TIMESVIDEO" section should be loaded.

Attachments (3)

2315_1450049551_2015-12-14_0120.png (190.8 KB) - added by passbrains 3 years ago.
2315_1450049551_2015-12-14_01201.png (161.8 KB) - added by passbrains 3 years ago.
2315_1450049551_2015-12-14_0118.png (303.3 KB) - added by passbrains 3 years ago.

Download all attachments as: .zip

Change History (8)

Changed 3 years ago by passbrains

Changed 3 years ago by passbrains

Changed 3 years ago by passbrains

comment:1 Changed 3 years ago by passbrains

1 - 14 Dec 2015 12:07:27 posted by Timo Scherf
Partly reproduced:
I can confirm that the loading performance is significantly slower.
But in my case the times video section is loaded and clickable.
Build 1.9.4.1500
On a Mac Book Air El Capitan Safari 9.0.1.

2 - 25 Jan 2016 10:01:42 posted by Scott Cheer
Arthur took a look into this to see if it was a Filter rule issue causing the problem but was unable to nail it directly to a filter rule. There is also some delay on Chrome - although, nowhere near as much as observed here.

comment:2 Changed 3 years ago by kzar

  • Cc kzar scheer arthur added
  • Description modified (diff)

I couldn't reproduce this with Adblock Plus 1.12.1. On both Chrome 52 and Safari 9.1 the TIMESVIDEO player was displayed and worked. The page did appear to render a little slower with Adblock Plus enabled but nothing significant.

Scott / Arthur can you still reproduce this or should I close the issue?

comment:3 Changed 3 years ago by kzar

  • Component changed from Unknown to Platform

comment:4 Changed 3 years ago by arthur

Tried it with ABP 1.12.1 on Chrome 52 and Safari 9.1.2 and wasn't able to reproduce it anymore.

comment:5 Changed 3 years ago by kzar

  • Resolution set to worksforme
  • Status changed from new to closed

Thanks Arthur, in that case I will close this for now.

Note: See TracTickets for help on using tickets.