Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#3588 closed defect (fixed)

TypeError when trying to add filter list on Chrome <47

Reported by: scheer Assignee: sebastian
Priority: P1 Milestone: Adblock-Plus-1.10.1-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: Blocked By:
Blocking: Platform: Chrome
Ready: yes Confidential: no
Tester: Scheer Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29334701

Description (last modified by scheer)

Environment

Windows 7 64 Bit
Windows 10 64 Bit
Chrome 43,44,45,46
Adblock Plus Versions:
1.10.0.1522
1.10.0.1523
1.10.0.1525
1.10.0.1526
1.10.0.1527
1.10.0.1528
1.10.0.1529
1.10.0.1530
1.10.0.1531

How to reproduce

  1. Click the ABP icon.
  2. Click 'Options'.
  3. Select 'Add Filter Subscription'

Observed behaviour

After selecting 'Add Filter Subscription', nothing happens.

Please note - I was not able to reproduce this in Chrome 48.

I was not able to find any errors in the development console on the background page, but found the following on the development console in the options page -

Fetch API cannot load chrome-extension://ldcecbkkoecffmfljeihcmifjjdoepkn/subscriptions.xml. URL scheme "chrome-extension" is not supported.
Uncaught (in promise) TypeError: Failed to fetch(…)

Expected behaviour

After selecting 'Add Filter Subscription', a drop-down selection should be available.

Attachments (1)

Capture.PNG (51.4 KB) - added by scheer 4 years ago.

Download all attachments as: .zip

Change History (13)

Changed 4 years ago by scheer

comment:1 Changed 4 years ago by scheer

  • Description modified (diff)

comment:2 Changed 4 years ago by scheer

  • Summary changed from User unable to add any Filter List and Easylist is not installed by default since Chrome 1.10.0.1522 to User unable to add any Filter List and Easylist is not installed by default since Development version 1.10.0.1522

comment:3 Changed 4 years ago by scheer

  • Description modified (diff)

comment:4 Changed 4 years ago by scheer

  • Description modified (diff)
  • Summary changed from User unable to add any Filter List and Easylist is not installed by default since Development version 1.10.0.1522 to TypeError when trying to add filter list with ABP for Chrome (1.10.0.1522 > 1.10.0.1531)

comment:5 Changed 4 years ago by scheer

  • Summary changed from TypeError when trying to add filter list with ABP for Chrome (1.10.0.1522 > 1.10.0.1531) to TypeError when trying to add filter list with ABP for Chrome (From version 1.10.0.1522 to version 1.10.0.1531)

comment:6 Changed 4 years ago by scheer

  • Description modified (diff)

comment:7 Changed 4 years ago by sebastian

  • Component changed from Unknown to Platform
  • Owner set to sebastian
  • Priority changed from Unknown to P1
  • Ready set
  • Summary changed from TypeError when trying to add filter list with ABP for Chrome (From version 1.10.0.1522 to version 1.10.0.1531) to TypeError when trying to add filter list on Chrome <47

comment:8 Changed 4 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

Apparently the fetch() API fails to fetch files from within the extension bundle before Chrome 47.

comment:9 Changed 4 years ago by sebastian

  • Resolution set to fixed
  • Status changed from reviewing to closed

Fixed: https://hg.adblockplus.org/adblockpluschrome/rev/16c17c83b8d2

New devbuild (1.10.0.1532) should be up within the next 30 minutes.

This change should be thoroughly tested on multiple Chrome versions, including at least any version older than 42, any newer than 46, and any version in between.

comment:10 Changed 4 years ago by sebastian

  • Milestone set to Adblock-Plus-1.10.1-for-Chrome-Opera-Safari

comment:11 Changed 4 years ago by scheer

Done. The 'Add filter subscription' button now allows users to add a subscription from the drop down menu.

Chrome 39,40,41,42,43,44,45,46,47,48
Adblock Plus 1.10.0.1532

comment:12 Changed 4 years ago by scheer

  • Verified working set
Note: See TracTickets for help on using tickets.