Opened 4 years ago

Closed 4 years ago

#3599 closed defect (fixed)

Puppet provisioning broken

Reported by: matze Assignee: matze
Priority: P1 Milestone:
Module: Infrastructure Keywords:
Cc: fhd, fred Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

The following error message is shown when running kick.py:

Updating data on the puppet master...
Provisioning filter20.adblockplus.org...
info: Retrieving plugin
info: Loading facts in /var/lib/puppet/lib/facter/iptables_version.rb
info: Loading facts in /var/lib/puppet/lib/facter/pe_version.rb
info: Loading facts in /var/lib/puppet/lib/facter/concat_basedir.rb
info: Loading facts in /var/lib/puppet/lib/facter/root_home.rb
info: Loading facts in /var/lib/puppet/lib/facter/ip6tables_version.rb
info: Loading facts in /var/lib/puppet/lib/facter/puppet_vardir.rb
err: Could not retrieve catalog from remote server: Error 400 on SERVER: Could not find node 'filter20'; cannot compile
warning: Not using cache on failed catalog
err: Could not retrieve catalog; skipping run

This issue seems to affect all servers, not only filter20 used in the example above.

Change History (2)

comment:1 Changed 4 years ago by matze

Node identification works again, after fixing an invalid character rendering base.yaml (within modules/private) malformed. Provisioning still fails due to another error though:

err: Failed to apply catalog: Could not find dependency File[/etc/apt/sources.list.d] for Exec[add-apt-repository-ppa:nginx/stable] at /etc/puppet/modules/apt/manifests/ppa.pp:33

comment:2 Changed 4 years ago by matze

  • Resolution set to fixed
  • Status changed from new to closed

Seems like I forgot #3587 being dependent on #3574, which caused the 2nd error. Everything working as usual after #3574 has been pushed.

Note: See TracTickets for help on using tickets.