Opened 4 years ago

Closed 4 years ago

#3601 closed defect (fixed)

Dashboard icons movement causes switch to webpage

Reported by: michal.kuric Assignee:
Priority: P1 Milestone: Adblock-Browser-for-iOS-1.3.0
Module: Adblock-Browser-for-iOS Keywords: salsita
Cc: mario Blocked By:
Blocking: #3282 Platform: Adblock Browser for iOS
Ready: yes Confidential: no
Tester: Scheer Verified working: yes
Review URL(s):

Description (last modified by michal.kuric)

Environment

iOS (all versions)
iPhone (all versions)
ABB 1.3.0-qa, (core 1.3.6-qa) (Build 801)
no filters enabled (doesn't affect)

How to reproduce

  1. Open ABB
  2. Click to address bar and swipe to dashboard
  3. Press and hold any dashboard icon
  4. Release it (or move around and release but do not change a position of the icon)

Observed behaviour

After releasing the icon already loaded web page is displayed

Expected behaviour

After releasing the icon it should show the context menu with "Edit" as the only option. Clicking "Edit" will lead you to the "Edit Bookmark" dialog. After clicking "Done" in the "Edit Bookmark" dialog, you should land on the dashboard again.

Change History (12)

comment:1 Changed 4 years ago by mario

  • Ready set

comment:2 Changed 4 years ago by michal.kuric

  • Description modified (diff)

comment:3 Changed 4 years ago by jand

  • Priority changed from Unknown to P1
  • Resolution set to fixed
  • Status changed from new to closed

comment:4 Changed 4 years ago by mario

  • Milestone set to Adblock-Browser-for-iOS-next

Batch modify: added Adblock-Browser-for-iOS-next milestone.

comment:5 Changed 4 years ago by scheer

Done.

This issue persists. Previously it was thought that the edit button should appear after moving the icon. But, actually as stated above, the issue is that by simply pressing and holding the Bookmark should now show the 'Edit' option, of which it does not. The issue remains that, by pressing and holding the Bookmark (without moving the Bookmark icon around) simply takes you to the Bookmark page and does not show the 'Edit' option.

ABB 1.3.0-qa (814)
iPhone 5S 16 GB - iOS 8.3
iPad Air 2 16 GB - iOS 9.1

Last edited 4 years ago by scheer (previous) (diff)

comment:6 Changed 4 years ago by scheer

  • Tester changed from Unknown to Scheer
  • Verified working set

comment:7 Changed 4 years ago by scheer

  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Verified working unset

comment:8 Changed 4 years ago by scheer

  • Blocking 3282 added

comment:9 Changed 4 years ago by jand

I cannot reproduce this issue. Can you try newer build?

Last edited 4 years ago by jand (previous) (diff)

comment:10 Changed 4 years ago by scheer

I just tested this on - 1.3.0-qa (824), iPhone 5C - iOS 9.2.1 and it still occurs.

To confirm, the above-mentioned steps state -

'3. Press and hold any dashboard icon.

  1. Release it (or move around and release but do not change a position of the icon)'

and -

'Expected behaviour

After releasing the icon, it should show the context menu with "Edit" as the only option.'

From this, my understanding is that if I press and hold the icon, wait some time (Not specified above), then the icon should move into a state that allows the user to select the 'Edit' option.

What in fact happens when pressing and holding the icon (even after some 30 seconds) and then releasing it is that the user is loaded into the icons related website.

If I press and hold the icon, then move the icon around and release, the 'Edit' option is then displayed.

comment:11 Changed 4 years ago by mario

  • Cc salsita removed
  • Keywords salsita added

comment:12 Changed 4 years ago by scheer

  • Resolution set to fixed
  • Status changed from reopened to closed
  • Verified working set
  • Upon retrying this with a real device, this issue no longer occurs. The user is able to press and hold the icon and receive the 'edit' option, without being loaded directly into the respective icons website.

ABB 1.3.0-qa (824)
iPhone 6 Plus - iOS 9.2.1

Note: See TracTickets for help on using tickets.