Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#3603 closed defect (fixed)

User can switch to bookmarks or history while editing dashboard items

Reported by: michal.kuric Assignee:
Priority: P1 Milestone: Adblock-Browser-for-iOS-1.3.0
Module: Adblock-Browser-for-iOS Keywords: salsita
Cc: mario, jand Blocked By:
Blocking: Platform: Adblock Browser for iOS
Ready: yes Confidential: no
Tester: Scheer Verified working: yes
Review URL(s):

Description

Environment

iOS (all versions)
iPhone (all versions)
ABB 1.3.0-qa, (core 1.3.6-qa) (Build 801)
no filters enabled (doesn't affect)

How to reproduce

  1. Open ABB
  2. Click address bar to open dashboard
  3. Click "+" button to add a bookmark to dashboard
  4. Tap "Bookmarks" or "History" (both are greyed out)

Observed behaviour

View is switched to bookmarks (or dashboard)

Expected behaviour

Switching to bookmarks or history during adding bookmarks to dashboard shouldn't be possible.

Change History (11)

comment:1 Changed 4 years ago by mario

  • Ready set

comment:2 Changed 4 years ago by jand

  • Priority changed from Unknown to P1
  • Resolution set to fixed
  • Status changed from new to closed

comment:3 Changed 4 years ago by mario

  • Milestone set to Adblock-Browser-for-iOS-next

Batch modify: added Adblock-Browser-for-iOS-next milestone.

comment:4 Changed 4 years ago by sven

  • Resolution fixed deleted
  • Status changed from closed to reopened

"Switching to bookmarks or history during adding bookmarks to dashboard shouldn't be possible."

It shouldn't be possible by clicking the navigation label nor by swiping to the left or to the right. The clicking approach is fixed, but you're still able to swipe to the right and to the left. In addition a new bug seems to be implemented while fixing that issue. The swiping method is not available anymore, after going into the dashboards edit mode and going back to the dashboard again.

comment:5 Changed 4 years ago by jand

  • Resolution set to fixed
  • Status changed from reopened to closed

I forgot to revert one condition. It should be fixed now.

comment:6 Changed 4 years ago by scheer

  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Tester changed from Unknown to Scheer

Done.

  • You can no longer select 'Bookmarks' or 'History' by tapping on the options whilst you are adding a Bookmark.

However, according to Sven's comment the user should not be able to swipe to these options either. This is not the case, the user is able to swipe to 'History' and to 'Bookmarks' whilst they are adding a bookmark.

ABB 1.3.0-qa (814)
iPhone 6 16GB - iOS 8.4.1
iPhone 5C 16GB - iOS 9.2.1

Last edited 4 years ago by scheer (previous) (diff)

comment:7 Changed 4 years ago by mario

  • Cc salsita removed
  • Keywords salsita added

comment:8 Changed 4 years ago by jand

Can you retest this issue? Build 814 does not contained fix of this issue.

comment:9 Changed 4 years ago by philll

  • Cc jand added

@jand:

  • If build 814 didn't contain any fix for this issue, please remove it from being listed in the release notes for build 814.
  • If you worked on this ticket, please assign it to yourself first.
  • If you fixed this now, please close this issue as fixed.
  • Please provide release notes for your new build (please always do so directly when providing a new build)

comment:10 Changed 4 years ago by jand

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:11 Changed 4 years ago by scheer

  • Verified working set
  • You are no longer able to select 'Bookmarks' or 'History' by tapping on the options whilst you are adding a Bookmark.

ABB 1.3.0-qa (824)
iPhone 6 Plus - iOS 9.2.1

Note: See TracTickets for help on using tickets.