Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#362 closed defect (fixed)

firefox: block image broken on youtube thumbnails (recommended videos)

Reported by: mapx Assignee: saroyanm
Priority: P3 Milestone: Adblock-Plus-2.6.5-for-Firefox
Module: Adblock-Plus-for-Firefox Keywords:
Cc: trev Blocked By:
Blocking: #472 Platform: Firefox
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/5681038109966336/

Description (last modified by trev)

firefox 29 beta
ABP last dev build 2.5.1.3800
easylist

go to youtube main page
Recommended videos
right click on the thumbs ==> block image
the same filter is created for all the thumbnails:

||s.ytimg.com/yts/img/pixel-vfl3z5WfW.gif

ABP for chrome works correctly ==> different filters for different thumbs

What to change

  • Introduce a sequential counter for the requests (request ID), each subsequent request should be associated with a higher request ID value.
  • When retrieving the request associated with a node, use the one with the higher request ID if there are multiple.

Hints for testers

This change might also have an effect on the blockable items functionality in Firefox, this one should still work correctly.

Change History (14)

comment:1 Changed 6 years ago by mapx

  • Description modified (diff)
  • Summary changed from firefox: block image broken on youtube to firefox: block image broken on youtube thumbnails (recommended videos)

comment:2 Changed 6 years ago by trev

  • Cc trev added
  • Priority changed from P2 to P3
  • Ready set

This is reproducible but not a regression, that's how Adblock Plus always worked. The problem is that two different images load for these thumbnails - first the pixel that is common for all of them, then the actual image. Adblock Plus doesn't distinguish between the two loads and offers you one of them "randomly". We should probably prefer whichever entry was recorded last.

comment:3 Changed 6 years ago by mapx

Like I said ABP for chrome manages to find the correct filter

comment:4 Changed 6 years ago by trev

That's because ABP for Chrome doesn't record the loads in the first place - the functionality there is broken in a different way.

comment:5 Changed 6 years ago by mapx

EHH is working fine (create the correct filter)
another report:
https://adblockplus.org/forum/viewtopic.php?p=99604#p99604

so, somebody needs to use EHH to find such a correct filter

comment:6 Changed 6 years ago by trev

  • Blocking 472 added

comment:7 Changed 6 years ago by trev

  • Description modified (diff)

comment:8 Changed 5 years ago by philll

  • Platform set to Firefox

comment:9 Changed 5 years ago by saroyanm

  • Owner set to saroyanm

comment:10 Changed 5 years ago by saroyanm

  • Status changed from new to reviewing

comment:11 Changed 5 years ago by saroyanm

  • Review URL(s) modified (diff)

comment:12 Changed 5 years ago by saroyanm

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:13 Changed 5 years ago by saroyanm

  • Milestone set to Adblock-Plus-for-Firefox-next

comment:14 Changed 5 years ago by trev

  • Description modified (diff)
Note: See TracTickets for help on using tickets.